Issue 80985

Summary: using Hex data into Calc
Product: Calc Reporter: npendleton <nat>
Component: formattingAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.2   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description npendleton 2007-08-23 21:30:36 UTC
Calc should have "Format > Cells > Other Bases" to permit easy entry and
manipulation of HexDecimal data.  If you have Mac Address, IP6 addresses, memory
address, or web colors, the data is provided in Hex. Currently text cell is the
only format support.  Validation, export and reformatting would be handy
features, such as adding prefixes such as "0x", zero padding, and the like.

The current work around is clumsy [dec2hex() and hex2dec()], requiring import
hex data in one column and a second column with hex2dec(celladdress), to convert
hex to decimal, and computation in decimal.

In cell manipulation:
The default functions called from "f(x)" button use single quotes, not double
quotes, so the function breaks!
hex2dec('ff') = 0 or #Value!
hex2dec("ff") = 255
and no quotes hex2dec(celladdress) works.
Comment 1 frank 2007-08-24 10:15:57 UTC
double to Issue 18134

*** This issue has been marked as a duplicate of 18134 ***
Comment 2 frank 2007-08-24 10:16:20 UTC
closed double