Issue 81002

Summary: Core implementation for direct cross-references
Product: Writer Reporter: Oliver-Rainer Wittmann <orw>
Component: codeAssignee: eric.savary
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, kami911
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description Oliver-Rainer Wittmann 2007-08-24 10:52:06 UTC
Implement the core for feature direct cross-references - see issue 25072
- Implementation of new reference format types
- Implementation of internal bookmarks for direct cross-references
Comment 1 Oliver-Rainer Wittmann 2007-08-24 12:58:38 UTC
implementation in progress in cws swcrossref01.
Comment 2 Oliver-Rainer Wittmann 2007-09-17 13:48:27 UTC
commit first changes to cws swcrossref01 - changed files:

Writer core implementation of new reference format types NUMBER,
NUMBER_NO_CONTEXT, NUMBER_FULL_CONTEXT:
/sw/inc/reffld.hxx, 1.6.464.1
/sw/source/core/fields/reffld.cxx, 1.20.444.1
/sw/source/core/txtnode/atrfld.cxx, 1.11.444.1
/sw/inc/SwNodeNum.hxx, 1.7.166.1
/sw/source/core/SwNumberTree/SwNodeNum.cxx, 1.11.52.1
/sw/inc/SwNumberTree.hxx, 1..1
/sw/source/core/SwNumberTree/SwNumberTree.cxx, 1.10.164.1
/sw/inc/numrule.hxx, 1.30.164.1
/sw/source/core/doc/number.cxx, 1.40.164.1
/sw/inc/shellres.hxx, 1.4.92.1
/sw/source/ui/utlui/initui.cxx, 1.13.92.1
/sw/source/ui/utlui/initui.hrc, 1.4.94.1
/sw/source/ui/utlui/initui.src, 1.41.76.1

removing unnecessary bookmark type HIDDEN_BOOKMARK:
/sw/inc/IDocumentBookmarkAccess.hxx, 1.3.420.1
/sw/inc/bookmrk.hxx 1.8.382.1
/sw/source/core/doc/docbm.cxx, 1.20.444.1
/sw/source/ui/dochdl/swdtflvr.cxx, 1.109.50.1

import/export of new reference format type for OpenDocument file format:
/xmloff/inc/xmloff/xmltoken.hxx, 1.8.4.1
/xmloff/source/core/xmltoken.cxx, 1.111.4.1
/xmloff/source/text/txtfldi.cxx, 1.65.18.1
/xmloff/source/text/txtflde.cxx, 1.77.18.1
Comment 3 thb 2007-09-27 20:36:01 UTC
*** Issue 82000 has been marked as a duplicate of this issue. ***
Comment 4 thb 2007-09-27 20:37:39 UTC
*** Issue 81998 has been marked as a duplicate of this issue. ***
Comment 5 Mathias_Bauer 2007-11-08 13:49:22 UTC
target 3.0
Comment 6 Oliver-Rainer Wittmann 2007-12-05 11:23:29 UTC
Further changes has been made in cws swcrossref01 - please refer to the cvs,
branch cws_src680_swcrossref01 for the changes.

Implementation is ready.
Comment 7 Oliver-Rainer Wittmann 2008-01-09 12:04:07 UTC
OD->ES: Take over for verification in internal installation set of cws swcrossref01
Comment 8 eric.savary 2008-02-18 21:07:19 UTC
Verified in CWS swcrossref01
Comment 9 thorsten.ziehm 2009-07-20 15:20:31 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues