Issue 81146

Summary: Implement various loop controls for Writer layout engine
Product: Writer Reporter: frank.meies
Component: codeAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: discoleo, issues
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: TASK Latest Confirmation in: ---
Developer Difficulty: ---

Description frank.meies 2007-08-30 09:49:23 UTC
Some of the critical loops in the Writer layout engine should be guarded by loop
controls to prevent the layout engine from locking up.
Comment 1 discoleo 2007-08-30 17:16:04 UTC
I think this affects one of my bugs. Added myself to the cc-list.
Comment 2 frank.meies 2007-08-31 06:31:49 UTC
fme->discoleo: Yes, i81033 will be fixed with this.
Comment 3 frank.meies 2007-09-04 15:33:44 UTC
A loop control basically detects an infinite loop and initiates some means to
stabilize the layout. Please note that loop controls might sometimes result in a
somewhat unexpected layout.
Comment 4 discoleo 2007-09-04 19:18:48 UTC
Is this really fixed? In version dev ? m... ?

Thanks.
Comment 5 frank.meies 2007-09-05 08:15:47 UTC
fme->discoleo: This has been implemented in cws loopcontrol. This cws is
targeted for OOo 2.4 and not yet integrated. You can check the state of this cws
here:

http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=SRC680%2Floopcontrol
Comment 6 frank.meies 2007-09-10 13:38:32 UTC
fme->mru: Ready for QA.
Comment 7 michael.ruess 2007-09-18 10:02:32 UTC
Checked the implementation in CWS loopcontrol.
Comment 8 michael.ruess 2007-10-23 15:19:53 UTC
*** Issue 82846 has been marked as a duplicate of this issue. ***
Comment 9 michael.ruess 2007-10-26 11:52:14 UTC
*** Issue 82996 has been marked as a duplicate of this issue. ***
Comment 10 michael.ruess 2007-10-26 13:55:01 UTC
Checked in 680m232.
Comment 11 michael.ruess 2007-11-05 09:21:53 UTC
*** Issue 83275 has been marked as a duplicate of this issue. ***
Comment 12 michael.ruess 2007-11-08 09:06:33 UTC
*** Issue 83425 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2007-11-08 11:23:34 UTC
*** Issue 61272 has been marked as a duplicate of this issue. ***
Comment 14 michael.ruess 2007-12-06 10:22:53 UTC
*** Issue 84239 has been marked as a duplicate of this issue. ***
Comment 15 michael.ruess 2007-12-06 16:34:47 UTC
*** Issue 84317 has been marked as a duplicate of this issue. ***
Comment 16 michael.ruess 2008-01-28 12:15:04 UTC
*** Issue 85488 has been marked as a duplicate of this issue. ***
Comment 17 michael.ruess 2008-03-11 13:19:19 UTC
*** Issue 86893 has been marked as a duplicate of this issue. ***
Comment 18 michael.ruess 2008-07-30 09:35:11 UTC
*** Issue 92257 has been marked as a duplicate of this issue. ***