Issue 81190

Summary: Content disappears when formating as two-column layout
Product: Writer Reporter: esibert <courrier>
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 2.2.1Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Document to reproduce the problem
none
New sample with wrong formatting none

Description esibert 2007-09-01 14:26:31 UTC
Use the attached document :
- Open it. 
- Select all the text page 2 (Samedi 4 mars 2001)
- go to menu Format|Columns
- select 2 for the number fo columns
- press Ok. OOo freeze with CPU usage at 100%. Under Windows, usually after 1
mn, depend on the sample, OOo is back (otherwise full crash) but the selected
area disappeared. You can see a small part of the selection on the top right of
page 2 (document is down from 3 to 2 pages). Under Ubuntu, it never recovered.

An other test :
- Open the attached document.
- Change format of style "Corps de texte fin" : uncheck Keep with next paragraph
- Select the same area as previously
- Format|Columns : 2 columns. This time, no freeze but still not well formatted.

P4 2.0 GHz 1 Gb
Windows XP SP 2 Home with 000 2.2.1
Ubuntu 7.04 with OOo 2.2
Comment 1 esibert 2007-09-01 14:28:31 UTC
Created attachment 47909 [details]
Document to reproduce the problem
Comment 2 Rainer Bielefeld 2007-09-02 09:25:06 UTC
I checked with "2.2.1  Multilingual German version WIN XP: [680m18(Build9161)]"
and can confirm the problem with "colonne.odt". Also visible with "2.0.2  German
version WIN XP: [680m5(Build9011)]". The text area will be formatted as selected
with 2 columns, but the text shrinks to an "invisible" small area. You can
search for text of that page, it will be fond, but not be shown.
I never saw that problem with my own documents.

@esibert 
Can you reproduce that with other new documents? My suspect is that the document
is damaged.
Comment 3 Mechtilde 2007-09-02 10:06:38 UTC
This only appears when it is activated: Evenly distribute contents to all columns.

I can confirm it with OOG680_m3
Comment 4 esibert 2007-09-02 11:20:55 UTC
After quick tests, I can't reproduce it with a new document. But I can still
produce strange results when using 2 columns in conjunction with "Keep with next
paragraph". Have a look to the new sample. Select all and switch to two columns.
Title will be alone in the first column and text start in the second one.

But let me explain all my problem. I think, this could be related. So my
documents is made by a set of texts. Each text have one or more paragraphs and
one author at the end. I want to keep the author with the end of the last
paragraph. As there is no option "Keep with previous paragraph", I applied "Keep
with next paragraph" to the last text paragraph. But then, this paragraph is
handle as not splittable. This is an unexpected behaviour for me, moreover than
"Do not split paragraph" is not checked and, Orphan and Widow options are
available. So I suspect some contradictions between a large unsplittable area
and columns formatting producing the bug.

Unchecking "Evenly distribute contents to all columns" seems to provide a good
workarround in my real document for the crash and the text vanishing. But not
for the problem shown in colonne_3.odt.
Comment 5 esibert 2007-09-02 11:23:42 UTC
Created attachment 47910 [details]
New sample with wrong formatting
Comment 6 michael.ruess 2007-09-03 15:40:59 UTC
MRU->OD: quite odd behavior. Select the text on page two and format as two
column section as described. It feels like a loop, but after 30-60 seconds, you
are back in the document - but the newly formatted content is missing.
Comment 7 Mathias_Bauer 2007-12-03 14:48:40 UTC
according to release status meeting -> 3.x
Comment 8 Marcus 2017-05-20 11:17:53 UTC
Reset assigne to the default "issues@openoffice.apache.org".