Issue 81213

Summary: Validate a cell by using the tabulation key being "Autocompleted"
Product: Calc Reporter: pagalmes.lists
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, matthias.mueller-prove, niklas.nebel
Version: OOo 2.2.1Keywords: usability
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
autocompletion_tabulation none

Description pagalmes.lists 2007-09-03 07:43:22 UTC
In Calc, when you start filling a cell, if the autcompletion is activated, you
can't use tabulation to validate the cell. It is annoying when filling lots of
cells.

Better behaviours would be:

1 - Validate and discard the proposed autocompletion

2 - Validate the autocompletion and leave the cursor in the cell (that means tab
validates the autocompletion and a new tab validates the cell)

3 - [Excel behavior] Validate the autocompletion and the cell (tab would go to
the next cell)

4 - other?

I don't know which behavior would be the best, but I think that number 2 and 3
are the best.
Comment 1 pagalmes.lists 2007-09-03 07:43:50 UTC
Created attachment 47923 [details]
autocompletion_tabulation
Comment 2 frank 2007-10-16 14:24:54 UTC
Hi,

Tab is used to toggle the suggestions for the autoinput feature. If you do not
want the suggestion just delete it and use tab to navigate to the next cell.

As you need a key to toggle the choices and the cursor keys are mostly used for
traveling through cells, we have to stay at the tab key for this feature.

I close this Issue as wontfix. If nn or mmp do have other points of view, they
may re-open this Issue.

Frank
Comment 3 frank 2007-10-16 14:25:16 UTC
closed wontfix
Comment 4 pagalmes.lists 2007-10-16 15:33:58 UTC
Well, I disagree and would change the default behaviour, which is currently
quite annoying, but that's just my point of view...

BTW, shouldn't this be decided by requirements?
Comment 5 pagalmes.lists 2007-10-16 22:57:35 UTC
nn, fst ->

Why is this a real issue? Because it impacts the newly added enhancement for OOo
2.4: "Enhanced Data Input in Calc"
(http://specs.openoffice.org/calc/ease-of-use/Enhanced_Data_Input.odt)

As soon as autocompletion is activated, you just can't use it because you can't
go to the next cell using the tabulation anymore...

To add a few more thought to the chat, here is a post where David Fraser already
said that this behaviour is annoying:

http://www.translate.org.za/blogs/david/archives/2006/05/23/T20_00_53/index.html


fst ->

The Excel  behavior for autocompletion is that it won't autocomplete until you
have enought characters to differentiate and have only ONE word matching.

I suppose that something better can be found...
Comment 6 frank 2007-12-12 15:02:03 UTC
re-assigned to requirements
Comment 7 frank 2007-12-12 15:03:07 UTC
removed me from cc
Comment 8 frank 2007-12-12 15:03:27 UTC
removed myself from cc
Comment 9 hagar_de_lest 2008-04-24 10:26:57 UTC
Seems to be a duplicate of Issue 18748.