Issue 81290

Summary: smart connectors when crossing another connector
Product: Draw Reporter: pagalmes.lists
Component: viewingAssignee: requirements <requirements>
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.2.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
A screen to display the RFE none

Description pagalmes.lists 2007-09-05 13:47:30 UTC
When connectors cross one another, it would be nice if they could jump one above
the other like in the screenshot.
Comment 1 pagalmes.lists 2007-09-05 13:48:15 UTC
Created attachment 47982 [details]
A screen to display the RFE
Comment 2 christian.guenther 2007-09-05 17:59:37 UTC
This is an enhancement
Comment 3 Joe Smith 2009-07-10 15:08:24 UTC
This looks like a duplicate of Issue 50971.
Comment 4 mbayer 2009-09-17 17:36:03 UTC
Duplicate. Please transfer your votes.

*** This issue has been marked as a duplicate of 50971 ***
Comment 5 Mechtilde 2009-09-22 20:23:30 UTC
duplicate -> closed
Comment 6 deezledog 2010-06-02 05:20:45 UTC
Note the Liang-Barsky line-clipping algorithm.

This works even if one or both segments are parallel to an axis, or if line
segments do not intersect at all.  Also faster than other algorithms.