Issue 81460

Summary: lines are omitted in OO slideshow of a ppt file
Product: Impress Reporter: Unknown <non-migrated>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: alan, i.hunt.bugs, issues, yba
Version: OOo 2.2   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
screenshot of PowerPoint slideshow
none
screenshot of OO slideshow: the link is cut off
none
screenshot of PowerPoint slideshow
none
screenshot of OO slideshow: the animation active on lines 2,4 instead of all the paragraph. And the third line is missing
none
The original ppt file
none
Link formatting lost when pptx file opened in OO
none
Lines missing in slides show mode when opening pptx in OO
none
Link cannot be line wrapped in OO
none
Lines missing in slide show mode in OO none

Description Unknown 2007-09-10 15:19:17 UTC
In OO slideshow of a ppt file some lines are omitted.
It happened both on WinXP and FC6 OS.
Comment 1 Unknown 2007-09-10 15:20:43 UTC
Created attachment 48131 [details]
screenshot of PowerPoint slideshow
Comment 2 Unknown 2007-09-10 15:23:04 UTC
Created attachment 48132 [details]
screenshot of OO slideshow: the link is cut off
Comment 3 Unknown 2007-09-10 15:26:02 UTC
Created attachment 48133 [details]
screenshot of PowerPoint slideshow
Comment 4 Unknown 2007-09-10 15:30:35 UTC
Created attachment 48134 [details]
screenshot of OO slideshow: the animation active on lines 2,4 instead of all the paragraph. And the third line is missing
Comment 5 Unknown 2007-09-10 15:31:28 UTC
Created attachment 48135 [details]
The original ppt file
Comment 6 christian.guenther 2007-09-11 16:23:55 UTC
According to the developer this is not a bug but a missing feature.
Comment 7 i.hunt.bugs 2011-09-24 21:17:55 UTC
C. Wiedemann, 2011-09-24

The original report contains two bugs:
1. Link formatting not preserved when opening PowerPoint file in Open Office
2. All lines in textbox not shown in slide mode when some lines animated

I have replicated both bugs on version OOo-dev 3.4.0, DEV300m106 (Build: 9582).

System:

Sony Vaio VPCP115KG
Intel Atom CPU Z540 @1.86 GHz 1.87 GHz, 2 GB RAM, 32-bit
Windows 7 Home Premium, SP1
MS PowerPoint 2010 

Steps to replicate

Steps to replicate bug 1 (link formatting):
1. Create a PowerPoint presentation with one slide
2. Enter a link in a text box. The link text must be long enough to cause the link to wrap to a second line. Enter an empty line after the link in order for the link to be automatically formatted: blue font colour and text underlined. See  attachment “Bug 81406_1.pptx” 
3. Save the file (.pptx)
4. Open the file in Open Office

Expected result: 
The link formatting is preserved and the link is displayed with blue font colour, underlined and with line wrap.

Actual result: 
None of the formatting is kept. The link text colour is black, there is no underlining and no line wrap.

Steps to replicate bug 2 (lines missing):
1. Create a new PowerPoint presentation with one blank slide
2. Create a text box on the slide by clicking the “Text box” button on the tool bar, and then clicking on the slide to place the box
3. Enter five lines of text in the text box (Calibri Body, 48 pt)
4. Animate lines 2 and 4 by high lightening one line at the time and selecting any animation from the tool bar (e.g. “Fly in”). See attachment “Bug 81406_2.pptx”
5. Save the file (.pptx)
6. Open the file in Open Office
7. View the slide show by pressing F5

Expected result:
Lines 1, 3 and 5 are shown. The first mouse click makes line 2 fly in and the second mouse click makes line 4 fly in.

Actual result:
Lines 1 and 5 are shown, whereas line 3 is missing. The first mouse click makes line 2 fly in and the second mouse click makes line 4 fly in. Line 3 is still missing. In Normal view, all fives lines are visible.

Follow-up tests

In my follow-up tests, I first investigated if the bugs were indeed related to PowerPoint, or inherent to Open Office.

Follow-up test #1: Link in text box in Open Office (Attachment “Bug 81406_1.odp”)
1. Create a new presentation in Open Office with one slide
2. Select slide layout “Blank Slide”
3. Press “F2” to create a text box, and place the text box by clicking on the slide
4. Enter a link in the text box
5. Press “Enter” to create an empty line below the link. This causes the link to be automatically formatted and the font colour is changed to blue.
6. Resize the text box. Drag one of the corners to make the text box narrower.

Expected result: 
Making the text box smaller causes a line wrap.

Actual result:
Changing the size of the text box doesn’t cause the expected line wrap. The size of the text box can be changed, but the text line with the link is unaffected. 

In order to determine if the link formatting is the problem, I ran a second follow-up test, entering a link but without the automatic formatting, i.e. I performed exactly the same steps as in Follow-up Test #1 except for step 5, which was left out. It turned out that if the link is not automatically formatted, making the text box smaller does indeed cause a line wrap. 

I also tried to save the Open Office file and reopen it, to see if the link formatting would be preserved, and it was (unlike when opening a PowerPoint file). The font colour was still blue.

My conclusion is that bug 1 is only partially related to opening PowerPoint files in Open Office. The font formatting is lost, but the line wrap issue is a problem inherent to Open Office and means that links that are automatically formatted cannot be line wrapped.

Follow-up Test #2: Animated text lines in Open Office (Attachment “Bug 81406_2.odp”)
1. Create a new presentation in Open Office with one slide
2. Select slide layout “Blank Slide”
3. Press “F2” to create a text box, and place the text box by clicking on the slide
4. Enter eight lines of text in the text box (Calibri Body, 48 pt)
5. Animate lines 3 and 7  by high lightening one line at the time and select “Custom animation” -> “Add” -> “Fly in” -> “OK”
6. Start the slide show by pressing “F5”

Expected result:
Lines 1, 2, 4, 5, 6  and 8 are shown. The first mouse click makes line 3 fly in and the second mouse click makes line 7 fly in.

Actual result:
Only lines 1, 2 and 8 are shown. The first mouse click makes line 3 fly in and the second mouse click makes line 7 fly in. Lines 4, 5 and 6 are still missing. In Normal view, all eight lines are visible.

My conclusion is that bug 2 is not related to opening PowerPoint files in Open Office, but a problem inherent to Open Office that means that all lines of not-animated text between the first and the last animated line of text in a text box will be missing in slide show mode, but visible in normal mode.

Additional follow-up tests that should be performed are
* Placing animated and not-animated text in separate text boxes
* Different types of animation (“Fly in”, “Appear”, etc)
* Mixing animated and not-animated text in bullet point or numbered lists
* Other animated objects such as shapes or images

Impact

Bug 1 will most likely occur quite frequently since using links in presentations is common. Reformatting all links in a presentation can be a lot of work, and lead to frustrated users. The inability to line wrap links is not consistent with comparable products such as PowerPoint, and should not be viewed as a missing feature. It is a bug.

Bug 2 is probably less frequently occurring than bug 1, but the impact is higher. Looking at the presentation in Normal mode the user is led to believe that the presentation is ok, and there is a risk that the problem with missing lines in slide show mode is not discovered until giving the presentation live, an experience that might deter people from using Open Office again. This behavior is not consistent with user expectations, or with comparable products such as PowerPoint, and cannot be considered a missing feature. It is a bug.

Summary

There are a total of three bugs in this report
I. Automatic link formatting (font colour and underlining) is lost when opening a PowerPoint 2010 file in Open Office
II. Links that are automatically formatted in Open Office cannot be line wrapped
III. All lines of not-animated text between the first and the last animated line of text in a text box are missing in slide show mode in Open Office

The original report concerns issue 1 in the list above. Issues 2 and 3 are wrongly reported as PowerPoint issues and should be reported correctly.
Comment 8 i.hunt.bugs 2011-09-24 21:21:10 UTC
Created attachment 76808 [details]
Link formatting lost when pptx file opened in OO
Comment 9 i.hunt.bugs 2011-09-24 21:22:18 UTC
Created attachment 76809 [details]
Lines missing in slides show mode when opening pptx in OO
Comment 10 i.hunt.bugs 2011-09-24 21:23:06 UTC
Created attachment 76810 [details]
Link cannot be line wrapped in OO
Comment 11 i.hunt.bugs 2011-09-24 21:23:50 UTC
Created attachment 76811 [details]
Lines missing in slide show mode in OO