Issue 81665

Summary: page size clipped or incorrect for certain measurement units
Product: Draw Reporter: Joe Smith <jes>
Component: uiAssignee: Armin Le Grand <Armin.Le.Grand>
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues, masaya.k, rainerbielefeld_ooo_qa
Version: OOo 2.3 RC3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Joe Smith 2007-09-17 17:05:18 UTC
Issue 4219 relaxed the maximum page size for Draw documents to 3m x 3m. Because
the page size value (Format > Page dialog) is clipped to certain values,
conflicts arise with the standard page sizes for some measurement units.

Note: "UoM" refers to Tools > Options > OO.org Draw > General > Unit of measurement

E.g. for UoM="millimeters", page size is clipped to 300x300 mm, so standard page
sizes larger than A4 or US Letter are silently clipped to 300mm.

Some page sizes are also clipped for UoM="points", although there the clipping
limit is 3000 points, so fewer page sizes are affected.

Also, although this may not be a bug, when the UoM="inch", the page size is
clipped to 300 inches, which is 7.62m (i.e. larger than the 3m limit mentioned
in Issue 4219).

Here are some paper size/UoM combinations that are clipped(*):

    UoM:cm      in      mm      pt      pi
(Max)   300.0   118.1   3000*   8504*   709*
A0      118.9   46.8    1189*   3370*   281
A1      84.1    33.1    841*    2384    199
A2      59.4    23.4    594*    1684    140
A3      42.0    16.5    420*    1191    99
A4      29.7    11.7    297     842     70
Letter  27.9    11.0    279     792     66
Legal   35.6    14.0    356*    1008    84
Tabloid 43.2    17.0    432*    1224    102
B4(JIS) 36.4    14.3    364*    1032    86
B4(ISO) 35.3    13.9    353*    1001    83
Comment 1 Joe Smith 2007-09-17 17:17:27 UTC
Oops. Hardly seems necessary, but...

Steps to reproduce:

1) File > New > Drawing
2) Tools > Options > OO.org Draw > General > Unit of measurement = "millimeter"
3) Format > Page > Page > Paper Format = "A3"

Note that the "Height" entry has clipped at 300mm, instead of the correct 420mm
for A3 paper.

3a) Format > Page > Page > Paper Format > Width = "3m" (user enters text)

Note that the value clips to 300mm -- not quite 3m ;-)

Workaround:
Set UoM="inch". The page size can then be set for any standard page size, or any
user-entered page size up to 300x300 inches (7.6m). Then change the  UoM back to
millimeters.

This seems to work fine--the large page size is preserved on saving/re-loading
the file; other problems are untested/unknown.
Comment 2 wolframgarten 2007-09-28 09:10:02 UTC
Reproducible. Reassigned.
Comment 3 Rainer Bielefeld 2007-10-14 10:03:47 UTC
I believe it's a DUP, but for first I will mark it "depends on"  Issue 81809
Comment 4 Martin Hollmichel 2007-11-09 17:02:03 UTC
set target from 2.x to 3.x according
http://wiki.services.openoffice.org/wiki/Target_3x
Comment 5 Joe Smith 2007-11-09 18:12:59 UTC
This issue should be closed, not retargeted:

1) I agree, Issue 81809 is the same issue.

2) Issue 81809 is a P2, and thus not eligible for retargeting

3) Further, the issue is a regression, because the problem was introduced by
changes for Issue 4219.

Therefore it makes no sense to re-target this issue; it should simply be closed
and dealt with through Issue 81809.
Comment 6 Armin Le Grand 2007-12-06 10:26:36 UTC
AW: Setting to duplicate...

*** This issue has been marked as a duplicate of 81809 ***
Comment 7 Armin Le Grand 2007-12-06 10:27:31 UTC
AW: Closing as proposed.