Issue 81677

Summary: request for an auxilliary application to toggle file associations
Product: General Reporter: pintooo15 <pintooo15>
Component: uiAssignee: Olaf Felka <olaf-openoffice>
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues, thorsten.martens
Version: OOo 2.2.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
screenshot of an existing file association setting program none

Description pintooo15 2007-09-18 02:06:01 UTC
Many discussions on users and discuss mailing lists and the MPlayer for Windows
project gave me an idea for a feature that would help OpenOffice users solve a
lot of their confusion that arises from the missed file association setting for
MS Office formats screen during install. Although these associations can be
toggled by Tools>Folder Options... in Windows Explorer, there are virii which
disables Folder Options... and then the usual procedure of right clicking on a
(hopefully) existing file and using the Open With>>Choose Program option.
A separate application or the (quickstarter itself), can check for changed file
associations (only for the file types that OO.o can understand very well. At the
same time, an UI could be added to configure a custom set of file<->application
association.

Thanks for OpenOffice.org :D
Comment 1 Mathias_Bauer 2007-09-21 08:59:00 UTC
I see a problem with this approach if it is done inside the application. At
least we also should add this as an option into the setup so that it can be done
for all users at once. Perhaps that makes it unnecessary to have this in the
application also.

BTW: I think that there is at least one duplicate for this issue.
Comment 2 pintooo15 2007-09-21 16:03:39 UTC
Created attachment 48405 [details]
screenshot of an existing file association setting program
Comment 3 pintooo15 2007-09-21 16:05:49 UTC
[quote]BTW: I think that there is at least one duplicate for this issue.[/quote]

could be. could be because i am not good in wording my searches. hope the
screenshot makes things clear.
Comment 4 thorsten.martens 2007-11-23 08:33:44 UTC
TM->OF: please have a look at mba's comment and decide if this should go to an
appropiate developer or to "requirements", thanks !
Comment 5 Olaf Felka 2007-11-23 10:13:54 UTC
I don't see this as an Install feature. It's an overload when you see the OOo
software the first time to decide which mime types should be opened by OOo. We
should keep the global settings for MS doc types in Setup and write the registry
keys accordingly. But I think that it makes more sense to have it more detailed
as an Options in Tools. Seee issue 17718 and issue 4414

*** This issue has been marked as a duplicate of 17718 ***
Comment 6 Olaf Felka 2007-11-23 10:14:26 UTC
duplicate