Issue 81706

Summary: RTF: cyrillic document should be recognized when system is russian
Product: Writer Reporter: nick_tz <nick_tz>
Component: viewingAssignee: openoffice
Status: RESOLVED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, Mathias_Bauer
Version: OOo 2.3   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
URL: http://nick-tz.narod.ru/test.RTF
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Looks also bad in MS Word none

Description nick_tz 2007-09-18 16:18:59 UTC
RTF file with russian text is displayed incorrectly. It looks like a wrong code
page.
The same file looks normal in MS Office (MS Word 2002 SP3)
Comment 1 michael.ruess 2007-09-19 09:42:46 UTC
Created attachment 48322 [details]
Looks also bad in MS Word
Comment 2 michael.ruess 2007-09-19 09:49:30 UTC
It looks that there is not information about the codepage in the attached RTF
file. When I open the mentioned RTF in MS Word (even in a Russian / Cyrillic
environment), it looks as displayed in the attached screenshot.
Comment 3 nick_tz 2007-09-20 06:34:07 UTC
There is correct view in WordPad also (in my environment).

As for MS Word. May be it helps.
From system info:

Application name	Microsoft Word
Version	10.0
Build	6612
Language	English (United States)
System language designation	Russian (Russia)
	
Documents open	1
Document name	test.RTF
Document path	D:\Tmp\test.RTF
Document size	28.7 KB
Document create date	17.09.2007 17:34:00
Comment 4 michael.ruess 2007-09-20 12:41:17 UTC
MRU->HBRINKM: it does not look, that the attached RTF file contains any codepage
information. Opening this in a Western environment, the correct symbols won't
even be displayed by MS Word 2003.
But when the system language is Russian, it is correctly displayed in MS Word.
This should also Work in Writer then.
Comment 5 michael.ruess 2008-05-14 06:49:50 UTC
*** Issue 89423 has been marked as a duplicate of this issue. ***
Comment 6 Mathias_Bauer 2008-06-04 12:25:00 UTC
IIRC we fixed that already (2.4?). Please check with a current build.
Comment 7 michael.ruess 2008-07-04 12:18:28 UTC
*** Issue 91297 has been marked as a duplicate of this issue. ***
Comment 8 michael.ruess 2009-03-24 15:00:42 UTC
*** Issue 100483 has been marked as a duplicate of this issue. ***
Comment 9 michael.ruess 2009-03-25 10:31:50 UTC
MRU->MBA / HBRINKM: this one is fixed in OOo 3.1, occurred last in 3.0.1. But I
could not find a 3.1 target issue handling this for OO 3.1?
Issue 89423 is also fixed; issue 91297 and issue 100483 are not fixed, I will
reopen these.
Comment 10 Mathias_Bauer 2009-03-25 13:00:16 UTC
These are strange findings. The fix I remembered was issue 68639 that was fixed
for 2.4. I have no idea why this did not fix the current problem and what fixed
it instead. 

The fix in issue 68639 IIRC was that we added a hard-coded encoding fallback for
some languages (making OOo on all platforms mimic the way Word might do it on
Windows).

Anyway, I think I will leave a similar comment in the issues that are still not
fixed and we forget about this one.