Issue 81895

Summary: Background settings for all pages fails for individually changed slides.
Product: Impress Reporter: isr81 <isr81>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.3   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description isr81 2007-09-24 13:58:48 UTC
When changing the background color of a slide via Format --> Page -->
Background, a dialog appears which asks if the new setting will be applied to
all the pages of the presentation.
When choosing "No" in that dialog, the current slide's color is changed
individually, as expected. Changing the background color again, and answering
"Yes" to the dialog, the color of the individually changed slides remains the
same, while the rest change correctly.
Comment 1 isr81 2007-09-24 15:47:37 UTC
I should add that when applying the layout of the master pages, the background
changes are correct.
Comment 2 wolframgarten 2007-09-27 14:01:19 UTC
Reproducible. Reassigned.
Comment 3 merkri 2008-01-26 17:43:52 UTC
I'm not sure whether or not I should comment here, or open a new issue, because
this issue has came up in the process of trying to figure out a much bigger set
of issues. I.e., this issue is one that I have problems with, but I came across
it when trying to deal with another, related issue with the background.

Basically, I get the same problem described here. I can also reproduce it using
the "styles and formatting" toolbar/window. However, background changes through
the "styles and formatting window" don't affect those through the Format -->
Page --> Background dialog, and vice-versa.

The bigger problem that led to me discovering this issue is that background
changes don't appear in the main editing window, but do appear in the preview
window and in the slideshow. E.g., if I reproduce the bug here, there's an added
issue that all of these changes that occur or don't occur only apply to the
preview window, and not the editing window. 

In other words, none of the background changes that I make appear in the editing
window at all. If, for example, I change the background to a dark color or an
image, it will appear (nonwithstanding the issues above) only in the preview
window, and not the main editing frame. This makes it difficult or impossible to
edit the slide, because the font will change to a lighter font--consistent with
the preview window change--and if this is white, you have a white font on a
white background. 

Basically, I can't get background changes to appear in the editing window, plus
the other issue here with the preview window.

I'm using the 2.3.1 version on Windows XP.
Comment 4 Marcus 2017-05-20 11:11:45 UTC
Reset assigne to the default "issues@openoffice.apache.org".