Issue 81935

Summary: Drawing anchored in TextFrame are not exported to MsWord
Product: Writer Reporter: maison.godard
Component: save-exportAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, marcelly.bernard, rbircher
Version: OOo 2.3   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
source odt file
none
saved msWord file
none
saved rtf file
none
saved PDF
none
the image for teh odt file none

Description maison.godard 2007-09-25 14:45:54 UTC
If an image is anchared in a TextFrame, it is not exported to MsWord or RTF
format. It get lost

If it is anchored at page, it is exported correctly. Ok.
In any cases export to PDF is ok

* reproducing:

insert text frame
in the frame, insert image
anchor it at frame or at paragraph (that is in the text frame)
export to msWord
close file
re-open the .doc file

the image is lost

(reproductible on many platforms and by macro)
attached file shows the behaviour
Comment 1 maison.godard 2007-09-25 14:46:30 UTC
Created attachment 48482 [details]
source odt file
Comment 2 maison.godard 2007-09-25 14:47:08 UTC
Created attachment 48483 [details]
saved msWord file
Comment 3 maison.godard 2007-09-25 14:47:47 UTC
Created attachment 48484 [details]
saved rtf file
Comment 4 maison.godard 2007-09-25 14:48:20 UTC
Created attachment 48485 [details]
saved PDF
Comment 5 maison.godard 2007-09-26 09:57:31 UTC
Created attachment 48504 [details]
the image for teh odt file
Comment 6 bmarcelly 2007-09-26 13:22:15 UTC
For what it's worth, some test results with older versions of OOo : 1.1.5 and 2.2.1. 
I did not yet switch to 2.3.

Creating a word 97 document containing an image inserted (not linked) to a text frame.
If the image is anchored in the frame as character, at character, at paragraph : the 
image is still visible. OK, both in 1.1.5 and 2.2.1.
If the image is anchored at frame, the image disappears. Both in 1.1.5 and 2.2.1.

Creating a word 97 document containing a linked image in a text frame.
OOo 2.2.1 displays the word document with a broken link.
OOo 1.1.5 displays the word document correctly (image remains visible).
A linked image inserted ouside a frame is correctly displayed (although after an extra 
delay with OOo 2.2.1).
Comment 7 py_samyn 2007-10-03 11:13:34 UTC
For information : I have downloaded the files (attachments)

In the odt the images are "Draw objects" and I confirm the bug (not exported 
to Word) but if i insert the image (Insert / Picture / From file) the images 
are of course "Graphics" and they are exported to Word...

In some circumstances (?), i encounter a similar problem : after an export to 
Word format, the height of the image (inserted in a frame with Insert / 
Picture / From file) is set to 0.04cm
Comment 8 Raphael Bircher 2007-10-05 03:27:02 UTC
set me on CC: becaus a Problem with .doc export with background image. I'm not
sure it's the same Problem

Maybe i write better a new issue

Raphael
Comment 9 michael.ruess 2007-10-25 13:59:13 UTC
These are not images - these are drawing objects.
Problem is, that in MS Word it is not possible to anchor drawings inside frames.
See issue 25756 for further information.

*** This issue has been marked as a duplicate of 25756 ***
Comment 10 michael.ruess 2007-10-25 14:00:09 UTC
Closing duplicate.