Issue 82060

Summary: [VI] Window titlebar character display errors in Windows
Product: gsl Reporter: clytie
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.3 RC3   
Target Milestone: OOo 3.x   
Hardware: PC   
OS: Windows XP   
URL: ftp://ftp.linux.cz/pub/localization/OpenOffice.org/devel/680/OOG680_m5/Build-1/OOo_2.3.0_070911_Win32Intel_install_vi.exe
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot of Options titlebar
none
Screenshot of Page Style titlebar
none
Screenshot of Writer document titlebar
none
screenshot for comparison none

Description clytie 2007-09-28 13:48:33 UTC
I know Pavel said there is already a bug about this, but I couldn't find it after an hour of searching. :(

A user has reported that translated window titlebars in OpenOffice.org 2.3rc3 in Vietnamese do not 
display the correct characters. (It has taken us time to get reports like this, because very few people 
are willing to guess their way through the garbage-text Install Wizard (issue 81728) in order to install 
the build.)

Non-ASCII characters in the title-bars are replaced with other characters. The menus and the rest of 
the application display Vietnamese correctly: only the window titlebars are messed up.

Please see the three attached screenshots: title1, title2 and title3.

This is not a showstopper, but it looks messy.
Comment 1 clytie 2007-09-28 13:50:07 UTC
Created attachment 48580 [details]
Screenshot of Options titlebar
Comment 2 clytie 2007-09-28 13:50:48 UTC
Created attachment 48581 [details]
Screenshot of Page Style titlebar
Comment 3 clytie 2007-09-28 13:51:22 UTC
Created attachment 48582 [details]
Screenshot of Writer document titlebar
Comment 4 pavel 2007-09-28 13:58:42 UTC
.
Comment 5 philipp.lohmann 2007-10-08 15:27:58 UTC
target
Comment 6 philipp.lohmann 2007-10-22 17:45:23 UTC
Created attachment 49073 [details]
screenshot for comparison
Comment 7 philipp.lohmann 2007-10-22 17:47:02 UTC
The attachment shows how it looks on my system with the install set from pavel.
Of course my vietnamese is a little lacking, but it looks to me more right than
your screen shots. The question is, what do I need to do to provoke the error
you are getting ?
Comment 8 philipp.lohmann 2008-01-08 17:04:56 UTC
target
Comment 9 clytie 2008-05-26 08:21:37 UTC
It looks like we are still having this problem:
http://www.flickr.com/photos/vuhung/2515131349/sizes/o/in/set-72157605189854560/
This user is running DEV300_m10 on Windows XP.
The two titlebar strings are:
(background) Insert Table: Chèn bảng
(foreground) Auto-Format: Tự động Định dạng
The titlebar display appears to be using a Latin-1 or similar codeset, because it displays the e grave in « 
Chèn », but not any of the other vowels. e grave is represented in Latin-1, while the other accented vowels here are not.
Comment 10 clytie 2008-05-26 09:40:30 UTC
More examples from the same user:
http://www.flickr.com/photos/vuhung/2515131375/in/set-72157605189854560/
Titlebar should say:
Spellcheck(er): Kiểm tra Chính tả
http://www.flickr.com/photos/vuhung/2515956484/in/set-72157605189854560/
Styles and Formatting: Kiểu dáng và Định dạng
http://www.flickr.com/photos/vuhung/2515956628/in/set-72157605189854560/
Split table: Xẻ bảng
http://www.flickr.com/photos/vuhung/2515956752/sizes/o/in/set-72157605189854560/
Options > Language Setup > Language: Tùy chọn > Thiết lập Ngôn ngữ > Ngôn ngữ

There are lots more, but these are some examples.

Comment 11 philipp.lohmann 2009-09-09 10:49:05 UTC
I still cannot reproduce the problem - which unfortunately makes it impossible
for me to fix it.

SBA: perhaps you can reproduce it ?