Issue 82449

Summary: Gif Animations crash OO Impress
Product: Impress Reporter: drector <drector>
Component: viewingAssignee: thb
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: issues, utomo.prawiro
Version: OOo 2.3Keywords: needmoreinfo, regression, usability
Target Milestone: OOo 2.4   
Hardware: PC (x86_64)   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description drector 2007-10-09 20:57:03 UTC
Please help,

Medium sized gif animations (50 or more frames) appear to crash openoffice v
2.2.0 when the slide is viewed. Open office becomes very sluggish, and all
available memory is used up.

Thanks!
Dave Rector
Comment 1 wolframgarten 2007-10-10 08:04:53 UTC
Please attach the document if possible. Do you use the original OOo version from
the official site or from another ditributor? Did you send a crash report? If
so, which email adress did you use? Thanks in advance.
Comment 2 drector 2007-10-10 14:25:20 UTC
Thank you for your help,

Since the only way to get out of Open Office is a reboot, I never get a crash
report. The system becomes extremely sluggish because all available memory is
used, as well as all of swap space.

I have attached one of the files that is giving me trouble. Any advice, or work
arounds would be very helpful.

Since the file is larger than 1MB (~27MB) I am attaching a link to the file
here: http://sleep25.vetmed.wsu.edu/UAB_talk_10_05_07_slides_rector_v2.odp

Dave Rector
*:^)
Comment 3 drector 2007-10-10 15:44:37 UTC
Sorry, I forgot to mention that I am using the Open Office package that is
supplied with Fedora 7, and have done all the updates available.

Dave Rector
*:^)
Comment 4 wolframgarten 2007-10-11 12:40:19 UTC
First I thought this is a Fedora problem but then I was able to reproduce on
Suse with an original OOo2.3.0.
The critical slides are 21,23,24. When they are shown in the main view the need
of physical memory rises almost to the top. After reaching this also the
complete swap memory is used until the system gets stuck. Offie crashes then and
the memory is freed again.
In 2.0 final not the complete memeory was used so I see this as broken.
Comment 5 sven.jacobi 2007-11-28 13:21:45 UTC
sj->thb: you are having more experience with such kind of problems, it would be
nice if you can take over this issue.
Comment 6 utomo99 2007-12-01 06:32:21 UTC
regression, usability

as the version 2 work better
Comment 7 utomo99 2007-12-01 06:33:52 UTC
I guess this related or duplicate with Issue 82275
Comment 8 thb 2007-12-19 16:10:57 UTC
Yep, this seems to be a dupe.

*** This issue has been marked as a duplicate of 82275 ***
Comment 9 thb 2007-12-19 16:15:12 UTC
closing