Issue 82625

Summary: Forms cannot be printed anymore
Product: Base Reporter: Mechtilde <mechtilde>
Component: codeAssignee: marc.neumann
Status: CLOSED FIXED QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P2 CC: issues
Version: OOo 2.3Keywords: oooqa, regression
Target Milestone: OOo 2.3.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
document to reproduce the bug case none

Description Mechtilde 2007-10-15 13:30:45 UTC
You can't print a form with the data. The page view is greyed out.

If you export the form to pdf then you can also print the form directly.

I found this in 2.3.0 and in SRC680_m233

It works in 2.2.1 and in m222. So it is a regression.

Therefore I set P2
Comment 1 Mechtilde 2007-10-15 13:31:41 UTC
set keyword
Comment 2 Frank Schönheit 2007-10-18 08:20:34 UTC
Actually, "Page Preview" is grayed out in my 2.2/2.2.1, too. However, in
2.2/2.2.1 printing (either via File/Print or directly) works, while in 2.3,
nothing happens when trying to print.

I consider this regression important enough to target the issue to 2.3.1 -
finally, printing is a basic functionality.

fs->os: I am not sure whether this is the same root cause as the reports which
do not print anymore ...
Comment 3 Frank Schönheit 2007-10-18 08:21:11 UTC
Created attachment 48993 [details]
document to reproduce the bug case
Comment 4 Frank Schönheit 2007-10-18 08:22:05 UTC
the attached document allows reproducing the issue:
- open the document
- double-click the contained form to open it
- press Ctrl-P to print the form
=> nothing happens

In 2.2 / 2.2.1, the form was printed
Comment 5 Oliver Specht 2007-10-23 14:26:13 UTC
*** Issue 81705 has been marked as a duplicate of this issue. ***
Comment 6 Oliver Specht 2007-10-23 15:05:19 UTC
Fixed in cws os105 in 
sw/source/ui/uiview/viewprt.cxx
Comment 7 marc.neumann 2007-10-25 15:12:50 UTC
reassign to msc
Comment 8 marc.neumann 2007-10-25 15:14:59 UTC
verified in CWS os105

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=SRC680%2Fos105
Comment 9 Mechtilde 2008-01-08 09:35:58 UTC
now you can print a form but the print preview is still greyed out.

I test it with 2.3.1 and OOH_m1
Comment 10 Frank Schönheit 2008-01-08 11:56:58 UTC
While I agree that the non-availability of the page preview is an issue, I'd say
that this was not in the scope of this issue here - the page preview is
unavailable in 2.0, 2.1, 2.2.

Please submit a separate issue, and let this one here be dedicated to the (much
more serious) printing regression. Thanks.
Comment 11 Mechtilde 2008-01-10 13:17:34 UTC
then -> closed
Comment 12 christoph.lukasiak 2008-05-07 10:15:26 UTC
*** Issue 83221 has been marked as a duplicate of this issue. ***