Issue 82802

Summary: legend line samples too small to distinguish line dashes
Product: General Reporter: peterkessler <peter.kessler>
Component: chartAssignee: Regina Henschel <rb.henschel>
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: IngridvdM, issues, rb.henschel
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Example charts with indistinguishable line styles, and workaround.
none
Workaround using custom dashes. See lower chart. none

Description peterkessler 2007-10-19 19:19:39 UTC
I'm working with someone who is color blind.  I'm trying to make line charts
where the lines are distinguishable by line style.  But I find that the legends
give sample lines that are too small to be able to distinguish which line is
which.  This is probably also a problem for people making charts for publication
in print journals.  

I have a workaround, suggested by Frank Psotka: make the chart really big.  That
makes the legend really big, and allows the sample lines to be big enough to
show their details.

I've attached an example spreadsheet with charts.  Reproduce by making a line
chart with several sets of data.  Make all the lines black, choose different
line styles for the different lines.  E.g., "Fine Dashed" versus "Continuous"
and "2 dots 1 dash" versus "Fine dotted".  You will find it difficult to
distinguish the lines in the legend.

In the attached example, I've shown the chart first with colored lines so you
can see they are different (if you have a color display and aren't color
challenged).  Then I've used the workaround to make the chart 3x larger, and
edited the chart to make everything 3x larger (the fonts, the line thicknesses,
etc.)  That makes the legend large enough to distinguish the line styles.  Then
I copy-n-pasted the chart to a Drawing, saved it as a JPG, and shrank that by a
factor of 3, producing a chart (well, an image of a chart) with distinguishable
lines.  This is the chart I'd like to have in the first place.  Below that I
have the original chart with black lines, and finally I have an JPG of the black
and white chart after I've blown the chart up, exported it as a JPG and then
shrunk the JPG back down.  I think you can still tell the lines styles apart.

I shouldn't propose a solution, since you folks are the experts, but I when I
was fooling around with this, I thought I would want to be able to stretch the
legend horizontally, have the fonts stay as they were, but have the example line
segments get longer.  I hoped that way to be able to show them distinctly.  But
I can't change the size of the legend box.  I don't know if that's the right UI
solution, but it seemed to me like one way to do this.

I'm actually using StarOffice 8pp5, rather than OOo2.3 directly.

Hmm, now I have to figure out how to attach a file to an issue: there doesn't
seem to be a place to type in a file name to be uploaded.  I hope I can submit
this issue and then attach the sample file.
Comment 1 peterkessler 2007-10-19 19:22:22 UTC
Created attachment 49034 [details]
Example charts with indistinguishable line styles, and workaround.
Comment 2 frank 2007-10-19 19:24:34 UTC
wrong component, changed to Chart and re-assigned

Please use the latest Product Update for StarOffice 8 which is currently PU 8.
This is because PU 5 did not contain the new Chart Module.

Frank
Comment 3 peterkessler 2007-10-19 19:27:47 UTC
Oops.  I'm actually on StarOffice 8pp8, not 8pp5 as I said.  That's might be
crucial, since SO8pp8 has the new charting package from OO, rather than the old one.
Comment 4 kla 2007-11-05 12:43:15 UTC
@IHA: Maybe a idea for A11y?
Comment 5 IngridvdM 2007-11-07 12:33:56 UTC
->bm, please take over as you are implementing the legend.
I can confirm the problem. To solve it the legend keys must somehow be so big
that the different line dashes are shown completely. The problem got worse with
the new chart as the lines are drawn horizontally instead of diagonal in the
legend thus they are even shorter now.
Comment 6 bjoern.milcke 2007-12-04 13:44:49 UTC
Yes, for line charts, the legend key should be wider.

For the workaround it suffices to make the font of the legend larger, but of
course this looks not very nice.

What you effectively did by enlarging and shrinking again, is to use line dashes
with smaller distances. I would suggest to use different dashes as a work-around
for your problem. If the list of available dashes does not suit you, you can add
more user-defined one with Calc or Draw. Select a line, chose "Line" and there
to "Line Styles". There you can define new ones and save them under any name.

Problem is, you have to close and reopen the document to have them available in
the chart. This is still an open issue, as well as being able to add line dashes
directly in the chart. However, once reloaded you can use the new dashes. I'll
attach an example.

DevNote: The system for generating legend icons should be adapted, such that the
width of a legend key may be dependent on the symbol type used. Currently all
symbols have the same (bounding box) size, which is partly empty (e.g. for
boxes) If I would make the keys wider, there would be more spaces wasted for
boxes, so such a flexible systems seems more appropriate.
Comment 7 bjoern.milcke 2007-12-04 13:45:34 UTC
setting target
Comment 8 bjoern.milcke 2007-12-04 13:46:33 UTC
Created attachment 50086 [details]
Workaround using custom dashes. See lower chart.
Comment 9 peterkessler 2007-12-04 17:58:40 UTC
You are cheating!  Your lower chart uses a legend with Albany 13.2 point
characters.  The upper one uses Albany 9.4 point characters.  We already knew
that using a larger font for the legend is a workaround.  

If you change your lower chart's legend to use 9.4 point characters, the line
samples for Dist1 and Dist2 are indistinguishable: a long dash, some space
(which, admittedly is different between Dist1 and Dist2 if you look really
carefully), and a dot.  But neither looks like a sample of the lines that are
Dist1 (dash dash) or Dist2 (dash dot dot).

I think you understand the problem, though, and have a fix in mind for OOo3. 
That's good enough for me.  I'll wait patiently for the fix.
Comment 10 IngridvdM 2008-07-03 11:39:43 UTC
change owner
Comment 11 IngridvdM 2011-02-07 13:38:34 UTC
Fixed in CWS chart52. Details are specified here:
http://wiki.services.openoffice.org/wiki/Chart2/Specifications/ChartLegend
Comment 12 IngridvdM 2011-02-08 11:51:34 UTC
Thomas, please verify in CWS chart52.
Comment 13 Regina Henschel 2011-02-08 19:07:05 UTC
The legend key becomes 1,6cm wide, so the different dash/dot lines can be
distinguished well.
The legend key width becomes 60% of font size for large font sizes. You will
notice it not for font sizes smaller than 76pt, because 1,6cm is the minimum
width, if at least one data series has got a dash/dot line.

I have tested it with the attached documents and with own documents, using Calc
and Draw.
So I set it to verified in CWS chart52.

(I don't know, whether I should change owner back to iha.)
Comment 14 IngridvdM 2011-02-08 19:50:04 UTC
Thanks a lot Regina! After verification the issue is kept by the one who has
verified it until the CWS is integrated into the product. After successful
integration the issue can be closed. The issue is only set back to the developer
if something went wrong and the fix needs to be changed.
So I set this issue to you. Thomas is informed that you might take over further
issues for testing. Thanks a lot again! :-)
Comment 15 Regina Henschel 2011-02-25 22:48:05 UTC
The line in the legend item is long enough to distinguish line styles. It is correctly integrated in DEV300m101.