Issue 83221

Summary: no printing from openbase 2.3
Product: Base Reporter: stegerpl <peter.steger>
Component: codeAssignee: dbaneedsconfirm <needsconfirm>
Status: CLOSED DUPLICATE QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.3   
Target Milestone: ---   
Hardware: All   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description stegerpl 2007-11-01 21:55:47 UTC
On my platform (AMD 64X2) with gentoo LINUX installation both the 
openoffice-bin (openoffice-bin/openoffice-bin-2.3.0.ebuild,v 1.5 2007/09/20 
13:25:59 suka) as well as the compiled package (openoffice-2.3.0.ebuild v 1.14 
2007/10/20 19:43:55 dertobi123) does not allow me to print from openbase. 

The print command (menu item as well as icon) is accepted but it is not passed 
over to the printing system (cups as well as direct printing via LPD). No 
error messages appear as well as no messages within the logs.

In addition the preview item is disabled (as menue as well as icon) but will 
be active after I export via PDF directly. Then I may print from within the 
preview. 

However also the export via PDF directly only shows the form sheet and the 
images but no text.

I am connecting to my database set up within openbase 2.1 via JDBC using Sun 
JRE 1.6.0

Please check for a bug - further information on request...

best regards

Peter L. Steger
Comment 1 Mechtilde 2007-11-01 23:29:14 UTC
where do you want to use the print command?

What do you want to print?

Do you install 32-bit version of OOo and Java?
Comment 2 stegerpl 2007-11-02 15:44:19 UTC
I tried to print from within openbase (oobase => open an existing database => 
open formsheet) by using both the menu item as well as the icon for direct 
printing.

As described I set up a database with a formsheet and I wanted to print the 
formsheet with one dataset (text, numbers and one image).

My general setup is 64-Bit Versions of all programs far long as available, 
which was not the case for OpenOOffice 2.2 and Sun Java 1.6.0 but I expect 
that OpenOffice 2.3 was 64-Bit in the bin as well as the compiled version and 
Java was build in a mixed version as can bee seen from the following output.

$ java -showversion
    java version "1.6.0"
    Java(TM) SE Runtime Environment (build 1.6.0-b105)
    Java HotSpot(TM) Server VM (build 1.6.0-b105, mixed mode)

I hope this may help you... If you need further info or experiments, please 
contact me.

Thanks

Peter
Comment 3 drewjensen.inbox 2007-11-13 01:11:32 UTC
Pretty sure this is another example of the same problem as in Issue 
#http://qa.openoffice.org/issues/show_bug.cgi?id=81705

I'm using x86_64 under Kubuntu 7.1 with SUN java - same problem, can not print 
a form or wizard created report, however the same workaround as in windows 
works here also. Save the form or report to an odt file, open it and it prints 
without a problem.

Sun Report Builder reports print directly without the problem.
Comment 4 christoph.lukasiak 2008-05-07 10:15:26 UTC
set to double

*** This issue has been marked as a duplicate of 82625 ***
Comment 5 christoph.lukasiak 2008-05-07 10:16:58 UTC
close duplicate

please do not hesitate to reopen if bug still occure after doublette is fixed

thx