Issue 83392

Summary: WRITER fails to undo automatically created hyperlink
Product: ui Reporter: norbert2 <norbert.notz>
Component: uiAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@ui <issues>
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 2.3Keywords: oooqa, regression
Target Milestone: OOo 3.0   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description norbert2 2007-11-06 20:04:58 UTC
Hi,

please ...

1. open a (blank) writer document

2. Enter a a URL (for example "http://www.test.de/")

3. Press RETURN:
Notice that the string has been changed to a hyperlink.

4. Press undo: The RETURN is removed. But the hyperlink should be removed.

5. Press undo a second time: The whole string is selected. But nothing seems to
be undone!

Expected behaviour is like MS Word (tested MSO 2003 SP3):
The first undo removes the hyperlink, the second one the line break.
Comment 1 Rainer Bielefeld 2007-11-07 06:06:44 UTC
I checked with "2.2.1  Multilingual German version WIN XP: [680m18(Build9161)]"
and can confirm the problem. 

This problem only occurs if you terminate the hyperlink string with <Enter>. A
hyperlink created by pressing the <Space> key will be removed as expected.

I see the same problem in CALC, but not in DRAW or IMPRESS text fields.

The problem also occurs with "2.3.0  Dev. Snapshot  WIN XP: [680m233(Build9228)]"

@norbert2
For what Platform / OS did you test?
Comment 2 michael.ruess 2007-11-07 07:09:34 UTC
MRU->FME: this also seems to be a problem of the CWS "automaticstyles".
Happens always, when a paragraph starts with such an "autoformat" hyperlink.
Worked fine in OO 2.1.
Comment 3 norbert2 2007-11-07 08:41:26 UTC
"@norbert2
For what Platform / OS did you test?"

Windows. I will test Linux today or tomorrow and report it here.


"I see the same problem in CALC ..."

In Calc this is something different in my opinion: In Calc all auto-corrections
cannot be undone if they are terminated by RETURN. For example the automatic
correction of two upper-case characters ath the beginning. It only can be undone
if terminated by space, like automatic hyperlinks.
So if it is planned to be changed for Calc, the behaviour must be changed for
all auto corrections and not only for hyperlinks, to keep uniformity.
Comment 4 norbert2 2007-11-08 22:34:15 UTC
The bug can be reproduced on StarOffice 8 Product Update 8 Linux.
Comment 5 frank.meies 2008-01-10 10:03:12 UTC
Target shifted to 3.0 (can't be fixed until code freeze).
Comment 6 frank.meies 2008-06-12 13:54:32 UTC
Second way to reproduce: Insert some text, select the whole paragraph, Insert ->
Hyperlink, undo does not work. 

The submitter of this issue also mentiones an other issue: 

[...] Expected behavior is like MS Word (tested MSO 2003 SP3): The first undo
removes the hyperlink, the second one the line break. [...]

I do not address this issue with my fix.

fme->norbert2: If you still think that the order of the undo steps is important,
please submit a separate issue for this.

Fixed in cws sw30bf06, thints.cxx 1.63.16.1
Comment 7 norbert2 2008-06-19 18:30:18 UTC
Hi fme,

thanks for working on this issue.

"I do not address this issue with my fix."

But why such an incomplete fix? If the hyperlink is terminated by a space
instead of RETURN, undo works as expected. This should also work for RETURN.

Why should I file a seperate issue? Since you tell me that this issue has not
been fixed like described and expected by users I reopen this issue.

-> REOPENED

(What will be the first release that introduces your changes? I cannot see them
in Dev300 m19.)
Comment 8 norbert2 2008-06-19 18:31:06 UTC
What exactly does your "fix" fix?
Comment 9 frank.meies 2008-06-20 07:40:55 UTC
fme->norbert2: Your bug report was like this: Something broke. Please fix the
regression and additionally change Writer's behavior. I fixed the regression.
Now Writer's behavior is like it used to be. I did not change the order of the
undo steps. First step: undo line break, second step: undo hyperlink. Just like
it used to be. If you think the order should be changed, please file a separate
issue. 
Comment 10 frank.meies 2008-06-20 08:05:23 UTC
Ready for QA.
Comment 11 frank.meies 2008-06-20 08:06:16 UTC
Ähhh. Not yet verified.
Comment 12 frank.meies 2008-06-20 08:06:56 UTC
.
Comment 13 frank.meies 2008-06-20 08:07:31 UTC
Ready for QA.
Comment 14 norbert2 2008-06-20 16:39:12 UTC
I have filed issue 90936.
Comment 15 eric.savary 2008-06-27 14:00:29 UTC
Verified in cws sw30bf06
Comment 16 michael.ruess 2008-07-11 13:01:47 UTC
Checked in DEV300m24.