Issue 83495

Summary: Copying a chart from Calc to Writer changes the chart!
Product: General Reporter: ajr225 <ajr225>
Component: uiAssignee: kla <thomas.klarhoefer>
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues, jbf.faure
Version: OOo 2.3   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Original file containing the chart in correct form
none
Writer file where chart was copied to - chart has changed inside. none

Description ajr225 2007-11-09 14:58:39 UTC
I created a chart in Calc with lines representing my data. In Calc, the chart
looks exactly how I want it. When I copy/paste it into Writer, the lines in the
chart change - the end of the line is drawn back to the x,y = (0,0) position.
This makes the graph essentially useless.

A side issue is that when plotting data points, eg as diamonds, they stay the
same size even when the chart is resized in Writer. So if you make the chart
small, the diamonds will still stay quite large and not scale proportionally.
Comment 1 ajr225 2007-11-09 14:59:19 UTC
Created attachment 49556 [details]
Original file containing the chart in correct form
Comment 2 ajr225 2007-11-09 14:59:56 UTC
Created attachment 49557 [details]
Writer file where chart was copied to - chart has changed inside.
Comment 3 Olaf Felka 2007-11-09 15:04:18 UTC
Reassigned
Comment 4 jbf.faure 2007-11-10 16:59:11 UTC
I reproduce the bug with OOG680_m8.
@arj225 : you can bypass the bug using Edit > Paste Special... > GDI metafile
instead of normal paste. This way you will insert an image which is not
modifiable within OOo-Writer.
Comment 5 kla 2007-11-19 08:16:12 UTC
Looks like an duplicate to i83180 and i75453

*** This issue has been marked as a duplicate of 75453 ***
Comment 6 kla 2007-12-05 11:30:45 UTC
closed as duplicate