Issue 83665

Summary: Can't Edit Custom colors on document created by another user
Product: Writer Reporter: aln <lucas.nunes>
Component: formattingAssignee: clippka
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: ace_dent, cmoulin, gerv-openoffice, issues, marc.galmard
Version: OOo 2.3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
URL: http://www.oooforum.org/forum/viewtopic.phtml?t=65634
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description aln 2007-11-15 14:41:06 UTC
As stated on OOo's Forum:

If someone sends me a document that includes Custom Colors, I can't use/edit 
them, or even check their RGB values on OOo 
I can only check those by using a third party application to read the pixel 
colors. 

This situation is very easy to test: create a custom color, use it, save your 
document, delete the custom color, open your saved document. The color is 
there, but... 

Clicking on a shape filled with a custom color and clicking the Area tool, the 
color appears as the fill color in the Area tab, but click on the Colors tab 
and back again, the fill color disappears so the fill box becomes black. Hmm... 
It should at least retain the defined color of the object, even if it can't be 
saved into a palette. But I guess if the fill could be retained, it should also 
be able to be saved...
Comment 1 michael.ruess 2007-11-15 16:26:05 UTC
Reassigned to ES.
Comment 2 eric.savary 2008-02-01 20:36:33 UTC
As described
Comment 3 gerv 2009-01-01 17:39:24 UTC
I've just hit this - I imported a word document with a table with some cells
having a background colour, and I couldn't make more of the cells the same
colour because there's no way of getting the colour the original author used
into the palette.

The fix here is to put an "Add New Colour..." button on the standard colour
picker. This would take you to the Colours section in the Options, prefilling
the R, G, B values with the values from the currently-chosen colour and (if it's
not an existing colour) giving it a name like "New Colour #1". One could then
just click "Add" to add the colour, or add a different colour, or whatever.

Gerv
Comment 4 keylevel 2009-04-30 15:18:38 UTC
Also means you can't redefine user colors within your own documents - I've
currently got to go and manually change 25+ instances of a color because it was
set incorrectly when the document was created.
Comment 5 ace_dent 2009-10-07 18:23:34 UTC
This problem would be addressed by:
Issue 28994 - Save new colors inside the document (make custom colors easily
available)

I am marking this as a duplicate, and encourage you to add comments and votes to
i28994.

To manage the many suggestions for enhancing the color palette, I have created a
meta-issue here:
Issue 105642 - Re-design and UI improvements for color palettes

The purpose of the new issue is for management only, it does not duplicate
specific design requests (that we wish to capture).

Many thanks,
Andrew

*** This issue has been marked as a duplicate of 28994 ***
Comment 6 ace_dent 2009-10-07 18:24:44 UTC
Closed.