Issue 84278

Summary: hyperlinks are broken in TOC
Product: Writer Reporter: mibraun <m-ooo>
Component: formattingAssignee: eric.savary
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: dma2002, issues, kpalagin, rainerbielefeld_ooo_qa
Version: OOo 2.3Keywords: oooqa
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
odm + sub documents that behave strange none

Description mibraun 2007-12-05 19:16:29 UTC
Hi,

I'm editing an odm file (global document), which contains a TOC.
I created the TOC to contain hyperlinks, which later on should be exported to a
pdf. Pager numbering is changed so that the TOC and the first pages are numbered
with i, ii, ... and then the content (re)starts numbering with 1,2,3,... .
I first noticed that the hyperlinks don't work in the PDF file.
I then checked that they also do not work in OpenOffice.

Clicking  on the link just makes the page scrolling so that the clicked item is
the first line of the page.

AZ
Comment 1 mibraun 2007-12-05 19:26:27 UTC
I just found out that this only appears the all links referencing to page >= 15 .
So my chapter one to two are working correctly, chapter three, the main entry is
also correct but all subsequent entries do not.
I cannot see anything bad there, they are all "Headline 1" or "Headline 2" styled.
Comment 2 Rainer Bielefeld 2007-12-06 04:46:59 UTC
Related to  Issue 57897?

@alfonsname:
Please attach a sample document!
What OS do you use?
Comment 3 michael.ruess 2007-12-06 07:27:58 UTC
Reassigned to ES.
Comment 4 mibraun 2007-12-06 11:21:37 UTC
Created attachment 50152 [details]
odm + sub documents that behave strange
Comment 5 mibraun 2007-12-06 11:23:11 UTC
I'm using Ubuntu Gutsy (7.10) and the shipped OpenOffice.Org 2.3 .
Comment 6 dma2002 2008-01-10 09:25:31 UTC
I have the same behaviour in OOo 2.2 on WinXP SP2 Eng+MUI.
Comment 7 kpalagin 2008-01-13 19:00:47 UTC
Confirming as per dma2002
Comment 8 eric.savary 2008-02-01 19:45:04 UTC
Please don't use plain text numbering but define the numbering under Tools -
Outline Numbering.

*** This issue has been marked as a duplicate of 29858 ***
Comment 9 eric.savary 2008-02-01 19:45:25 UTC
closed
Comment 10 mibraun 2008-02-04 22:58:44 UTC
thanks; though it is impossible achieve reasonable chapter numbering + toc in an
odm, where the single peaces the odm is made of do already know their number.