Issue 84441

Summary: Undo in a protected sheet
Product: Calc Reporter: redflagzhulihua <ooo.redflag>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, oc, peter.junge
Version: OOo 2.3.1 RC1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    

Description redflagzhulihua 2007-12-11 03:28:35 UTC
After we protect a sheet, we can use undo to cancel the protection easily.

suggestion: 
Clear the undo stack after protection;
Or
Require password to Undo.
Comment 1 frank 2007-12-12 12:26:47 UTC
Hi Frank,

IMO this should be closed as wontfix.

Clearing the undo stack would be really inconvenient because you can't easily
undo a sheet protection with one click anymore. As such cases may only occur in
spreadsheet development this is a bit of overkill I think. The same for
requesting a password, beside that you're not required to set a password.

Frank