Issue 8461

Summary: ability to cut just text without leaving a blank default cell back as additional function
Product: Calc Reporter: lars <lars_o_hansen>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Trivial    
Priority: P4 CC: alexanderemmanuelpacheco, issues, rodlockwood
Version: OOo 1.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description lars 2002-10-17 16:41:54 UTC
ability to cut just fonts without cutting borders, background colors etc.

cut from cut & paste.


I don't like it, that my font attributes, border attributes, borders etc. are 
gone, when I cut sth. There should be made an additional option available!


see also issue 8460 and issue 8454.
Comment 1 lars 2002-11-08 13:48:29 UTC
what does that mean?:

to cut just TEXT

the cell from which is cut does not loose its attributes like bold 
text, font type Verdana, so after I have cut from cell A and I type 
into cell A, the previously chosen attributes are still there, that 
means the typed text is bold then and has the font Verdana.
Comment 2 oc 2003-09-17 09:41:39 UTC
Hi Bettina, one4you
Comment 3 bettina.haberer 2003-12-01 11:30:45 UTC
Changing that behaviour would reduce the compatibility between Calc
and competitor.
Comment 4 lars 2003-12-01 11:43:09 UTC
but offering as another additional function puttble on the toolbar or
the context menu as soon as you've got customizable context menus;
btw.: you should then integrate sth. like auto-adjusted toolbars and
context menus by the number of times a function has been used (as an
option).
Comment 5 bettina.haberer 2003-12-01 13:04:17 UTC
For Q (OO.o 2.0) we try to not get more options. There is no way to
get it changed in that version. Perhaps in the future, but by now
there is no solution like customizable context menus in sight.
Comment 6 bettina.haberer 2004-01-23 18:58:13 UTC
*** Issue 8454 has been marked as a duplicate of this issue. ***
Comment 7 bettina.haberer 2004-01-23 19:01:26 UTC
In 8454 keeping the assigned formats is wishes too, but in that case not for
cut, liek this one, but for delete. 
Comment 8 frank 2007-04-11 11:42:42 UTC
*** Issue 75935 has been marked as a duplicate of this issue. ***
Comment 9 White Phoenix 2008-07-04 05:04:55 UTC
I am using Windows XP HE SP2 on a PC.
I also find this frustrating especially since, Works which is considered an
inferior program to most others, has no problem cutting information in cells and
leaving the custom formatting behind. This problem also occurs when a row or
column is deleted/cut.
Comment 10 White Phoenix 2008-07-04 05:06:00 UTC
I am using Windows XP HE SP2 on a PC.
I also find this frustrating especially since Works, which is considered an
inferior program to most others, has no problem cutting information in cells and
leaving the custom formatting behind. This problem also occurs when a row or
column is deleted/cut.
Comment 11 frank 2008-08-21 09:02:24 UTC
*** Issue 91368 has been marked as a duplicate of this issue. ***
Comment 12 orwel 2009-07-30 08:11:40 UTC
This malfunction is still present in OOo3.2.0 (DEV300m53). It is really not
helpful to change the format of the cells which are cut to default, mostly you
need to keep the attributes of the cells preserved. If there is compatibility
problem a Cut special function (like paste special) would be a solution.
Comment 13 bettina.haberer 2010-05-21 14:42:58 UTC
To grep the issues easier via "requirements" I put the issues currently lying on
my owner to the owner "requirements". 
Comment 14 White Phoenix 2013-09-12 23:18:18 UTC
How would changing the behavior of *editing* make the resulting file incompatible with other spreadsheet applications? They only know about the end result not how it was edited.

As for using the applications, well different applications usually do have variations in how some functions are performed. You either adjust, request a feature enhancement or find another application you like better.

Besides, look at it logically. You want to move the information without ruining your formatting. It just doesn’t make sense to leave a hole in your carefully formatted spreadsheet just because all the other spreadsheets do it.
Comment 15 alexanderemmanuelpacheco 2017-04-25 21:14:49 UTC
Hi guys, found this page after several years of using this software.

This is just about the only bug, and a massive one, that I've had with this software- and I'm pretty shocked to see it goes back to 2002?

To make sure I'm understanding correctly... 

- I have information in one cell I want to move to another, and replace the contents of that original cell with some different information.

- I CTRL-X cut "Text", in Liberation Serif 14, from cell A4 and then successfully CTRL-V paste it into cell A5.  "Text" now appears in A5, in glorious Liberation Serif 14.  Great.  All my formatting and formulas carry over, what a great piece of software this is.  

- I then enter new data into A4, "New text", hit enter- and WTF!?, it's entered as a tiny, ugly, *Liberation Sans size 10*.  A font and size that exist nowhere on my document.  I now need to manually fix that cell's font size and formatting.

So- cutting a cell completely removes all formatting from the cell and replaces it with what?  A default font and size it deems appropriate?  Is this changeable via templates or?

I use CTRL X/C/V constantly when making spreadsheets (as I'm sure many do) and this is a nightmare.  I'm actively destroying my formatting while I work.

To be clear- this has nothing to do with file compatibility or feature parity with any other product.  No software on earth works like this.  This is a bug.
Comment 16 Marcus 2017-05-10 21:32:42 UTC
duplicate

*** This issue has been marked as a duplicate of issue 28411 ***