Issue 84723

Summary: display error in ruler
Product: Writer Reporter: norbert2 <norbert.notz>
Component: codeAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P5 (lowest) CC: issues, kpalagin, Mathias_Bauer, mzasuwik, thomas.lendo, tml
Version: OOo 2.3.1Keywords: oooqa
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
ruler_680m241.png
none
Ruler before apply patch
none
Ruler after apply the patch
none
Patch which solve problem with enproper display numbers on ruler none

Description norbert2 2007-12-18 20:43:52 UTC
Hi.

I just have tested "OOo_2.4.0_071213_Win32Intel_install.exe".

Please have a look at the attached
screenshot:

http://www.openoffice.org/nonav/issues/showattachment.cgi/50357/OOo_2.4.0_071213_Win32Intel_install_ruler.png

If a zoom factor < 90% is chosen, the "19" is displayed and overlaps the ruler.

Solution: The "19" should not be displayed, like in current final releases.


Comment of fme in issue 1598:
"fme->norbert2: Thank you for your feedback. But the reported behavior (showing
19" at certain zoom levels) can also be observed in the current master (m239).
So this isn't a regression of this cws."
Comment 1 frank.meies 2007-12-19 20:02:34 UTC
fme->norbert2: [...] Solution: The "19" should not be displayed, like in current
final releases. [...]

I just checked OOo 2.3 (OOG680m5) and can reproduce the problem there as well.
Comment 2 norbert2 2007-12-25 12:24:09 UTC
norbert2->fme:

You are right.

I just have tested OOo 2.3.1 Windows and SO8 PU9 Linux.

Both show "19" at 195% zoom factor.
Comment 3 kpalagin 2008-01-06 16:06:42 UTC
Can't reproduce with 2.4m241 on WinXP.
Please recheck.
Comment 4 norbert2 2008-01-08 20:32:24 UTC
Download link for 2.4m241 windows does not work. :-(
Comment 5 kpalagin 2008-01-08 20:47:12 UTC
Yep - either bouncer or something else is broken.

Try "developer" folder on any of the mirrors at 
http://distribution.openoffice.org/mirrors/.
Comment 6 norbert2 2008-01-22 18:19:41 UTC
Created attachment 51079 [details]
ruler_680m241.png
Comment 7 norbert2 2008-01-22 18:20:18 UTC
m241 is affected, too: ruler_680m241.png
Comment 8 lohmaier 2008-07-15 17:08:14 UTC
definitely not a P3, a cosmetical issue that causes no other problems whatsoever.
Anyway: Confirmed (although I doubt that it will get fixed unless somebody adds
a patch, there are much bigger fish to catch...)
As it is a display-issue only, I think it is easy2dev, so keyword set to give
people a chance to find it.
Comment 9 gang65 2010-06-10 07:49:17 UTC
Created attachment 69896 [details]
Ruler before apply patch
Comment 10 gang65 2010-06-10 07:50:06 UTC
Created attachment 69897 [details]
Ruler after apply the patch
Comment 11 gang65 2010-06-10 07:51:13 UTC
Created attachment 69898 [details]
Patch which solve problem with enproper display numbers on ruler
Comment 12 gang65 2010-06-10 07:55:07 UTC
I successfully resolved problem with improper display of the numbers in rulers.

I also fix the bug with the offset between the numbers (see attached screenshots
for more details)

I attached the ruler_fix.patch 

I tested this patch on Ubuntu 10.04 and latest Openoffice snapshot.

Comment 13 Mathias_Bauer 2010-06-10 12:46:37 UTC
Oliver, please review the patch
Comment 14 Oliver Specht 2010-06-14 07:20:08 UTC
Patch is o.k.
Comment 15 gang65 2010-06-14 11:55:04 UTC
Is it possible to add this patch to OpenOffice.org?
Comment 16 tml 2010-06-14 12:00:09 UTC
Just a friendly word of advice: in general, one should not do both code fixes
and "cosmetic" changes like whitespace fixes or comment translation in the same
diff, as it makes it harder to see what the actual code changes are. But of
course I am not a maintainer of the code in question, so I am not complaining.
Comment 17 mzasuwik 2010-07-18 05:22:15 UTC
Will it be integrated with 3.3?
Comment 18 Oliver Specht 2010-07-28 12:39:20 UTC
Target changed to 3.4
Patch applied in cws os143
Comment 19 Oliver Specht 2010-11-03 10:16:27 UTC
Reassigned for verification
Comment 20 michael.ruess 2010-11-03 15:07:52 UTC
Verified in CWS os143.
Comment 21 michael.ruess 2010-11-16 15:57:08 UTC
Checked in DEV300m93.