Issue 85451

Summary: image scaling not uniform even when Keep Ratio set
Product: Impress Reporter: brutzman <brutzman>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CLOSED IRREPRODUCIBLE QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues
Version: OOo 2.3.1Keywords: needmoreinfo
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description brutzman 2008-01-21 20:46:03 UTC
image scaling not uniform even when Position and Sizing, Keep Ratio is checked

this defect makes it hard to rescale images without introducing distortion

the Keep Ratio box should not remain checked if image aspect ratio has been
changed from the original

once that capability is restored, a good check on the feature would be to have
proper aspect ratio restored if the Keep Ratio box becomes checked
Comment 1 christian.guenther 2008-01-22 09:53:42 UTC
In  my mind this is not a bug but an enhancement.
Comment 2 brutzman 2008-01-24 06:50:48 UTC
understood..  i'm thinking more strictly as a bug.  rationale:  it is hard to
tell on the screen, after scaling down (or up), whether or not you have
maintained the proper aspect ratio.  this distortion has mangled some of my
content, and it is only (and hopefully) caught after hi-quality printing when
the error becomes evident.

since the user can't determine whether or not their operation of the software
has caused a content error, i believe that this problem is best considered to be
a software error.

anyway, FYI.  please label it however you think best, just wanted to ensure that
the impact of this problem is understood.  thanks for your efforts.
Comment 3 brutzman 2008-01-24 15:03:27 UTC
my previous post was focused on the practicality of the workaround.

more precisely:  checking the box does not perform the labeled function and has
no apparent effect.  that is a bug.
Comment 4 dpizzica 2008-06-02 15:54:26 UTC
[Dee Pizzica 6/3/08]

I was able to recreate this issue in the 2.4.0 release of Impress (XP Pro OS)

I wish to add on to brutzman’s comments about why this is a bug that will 
negatively effect users. In addition to a user expecting the “Keep ratio” 
checkbox to maintain the proportions of the selected image, this is a feature 
present in MS Powerpoint (ver 2002 SP3).

In Powerpoint a user can right click on an image, select format picture and on 
the size tab check the box to “Lock aspect ratio.”  When a Powerpoint user 
attempts to drag the corner of an image to resize it, the resizing does force 
the image to maintain its proportions.

In Impress in order to maintain image ratio, the user must open the Picture 
and Size menu and adjust the values in the Width and Size fields in order to 
resize their image.  Because these adjustments do not occur in real time, the 
user must save changes and then potentially make additional adjustments.
Comment 5 cemkaner 2008-06-06 09:53:00 UTC
I must not understand the problem. Here's what I see in OOo 3.04 beta.

1. I create a new presentation
2. I add a graphic to the page (a jpg picture)
3. select the picture
4. Select Format | Position and Size to get the Position and Size dialog
5. Click "Keep ratio" 
6. My particular width and height are 4.84 W and 4.61 H. If I change values **in
this dialog**, the ratio is preserved. For example, if I change 4.84 to 5.84,
the height automatically changes to 5.56.

Therefore, this feature works (so far).

If I try to manipulate the image directly by grabbing a handle on the image and
dragging it, I can resize the picture any way I want, creating distortion. The
ratio is not preserved. Is this the "bug"?

I then do the same thing in PowerPoint 2007. 
1. New presentation, copy the picture from OOo and paste into powerpoint page
2. with the picture selected, click Format, click size to bring up the Size and
Position menu, and height and width are at 100%, click lock aspect ratio if not
already checked.
3. change Height and width changes (in the height / width boxes on this dialog).
Similarly, change the scaled height (100% to 110%) and scaled width changes too.
4. close the dialog, drag the middle handle to the right to stretch the picture
lengthwise, bring up the dialog and even though lock aspect ratio is still
stretched, my height is now 100% and my width is 126%.

So OOo 3.04 behaves essentially the same way as Powerpoint 2007.

If the goal is compatibility of the two products, then this behavior is a
feature, not a bug.
Comment 6 wolframgarten 2008-06-13 13:47:01 UTC
Pressing the SHIFT-key while sizing keeps the Ratio, too (as a workaround).
Changing to enhancement.
Comment 7 shaforostoff 2010-03-30 17:43:12 UTC
i too would like images to be resized keeping aspect ratio w/o need to press (and hence 
know about) SHIFT key, because most probably a user doesn't want to distort an image.

also this is the way powerpoint behaves.

If you want to keep the old behaviour available, then please change it to use e.g. ALT 
key.
Comment 8 cloo 2010-08-28 16:22:26 UTC
Still here in 3.3dev

I don`t agree that it`s just an enhancement: 
There is a checkbox with a described function presend, and it does not do 
anything. 

Enhancement could be removing non-functional elements like visual trash, but we do 
want it working!
Comment 9 charlie03m 2010-09-14 21:35:19 UTC
Hi,
   I ran into this issue running writer 3.2.0 under XP, 
pasting from an Paintshop.  If the page formatting constrains 
the size of a graphic, say it is too tall for the page at 
the native size, even if "keep ratio" is checked, the image 
aspect ratio is distorted before the "picture" dialog box 
can be open.  The original aspect ratio is lost and cannot 
be recovered except by going back to the source and resizing 
it.  The "shift" key trick doesn't help because the damage 
has already taken place. 
   As another user noted, I did not notice the distortion 
until I printed the file, and lost a lot of time recovering 
from it.  This is definitely a bug, I'm appalled that anybody 
is chewing up time arguing about it.
Comment 10 hardy314 2010-11-13 17:23:45 UTC
This definitly is a bug. A normal user will not understand nor like the standard
behavior of Impress when rescaling an image with the mouse. Please let the
aspect ratio stay fix as default behavior.

PS: My wife just stopped using Impress and went back to Powerpoint after she
tried to create a presentation with a lot of photos in it...

Please change the status from UNCONFIRMED to something else, it definitly still
happens in OOo 3.2.1.
Comment 11 Edwin Sharp 2014-04-21 08:46:14 UTC
Please specify steps to reproduce bug.
Comment 12 Edwin Sharp 2014-05-05 06:15:58 UTC
No info from author.