Issue 85791

Summary: Anchor of a picture in cell jumps to cell above
Product: Calc Reporter: kai_m <kai_m_ooo>
Component: formattingAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues, kpalagin
Version: OOo 2.3.1   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description kai_m 2008-02-01 10:07:47 UTC
Insert a picture by file to (for example) cell C10, set anchor to cell. Anchor is now in cell C10.  Now 
increase the hight of row 9 and the anchor will move to C9. After this move, it stays there, even if I 
increase the hight of row 9 again. It does not depend why the hight increases. It also happens if the 
hight increases because of inserting text with word wrap in a col of the row above.

If i decrese the hight of row 9 the anchor stays in cell C10. After this I can increase the hight of row 9 
without moving the anchor out of cell C10.

I tryed to set the anchor after inserting the picture by file to page and back to cell, does not help.

An other defect in maybe the same manner is that many pictures at a column get y-offsets in high row 
numbers (i.e. row 300). 

I can reproduce it with OOo 2.3.1 on W2K (both german language) and with NeoOffice 2.2.2 Patch 8 on 
MacOS X 10.5.1 and wiht older versions of OpenOffice.

Hope that help to fix the defect.
Comment 1 kai_m 2008-02-01 10:55:46 UTC
I found out, that the workaround I described (to decrease the hight of the row above and than to increase 
the hight of the row above) will not work all the time. It seems to work in that way: decrease it, klick to 
the picture than increase it.
Comment 2 kpalagin 2008-02-03 17:30:55 UTC
Confirming with 2.3.1 and 2.4m5 - as described.
Might be related to http://www.openoffice.org/issues/show_bug.cgi?id=59745.
Comment 3 kai_m 2008-06-12 16:53:54 UTC
Hi K. Palagin,

I don't think, that this issue is related to 59745. The anchor of the notes are moving with the cells, and 
the position of the notes seems to be stored absolutely on the sheet. In this issue (85791), the anchor 
(of pics) is moving into an other cell. I'm not worked into the source code, but  for me this seems to be 
quite different.

Therefore I hope not to wait for a fixed issue 59745 to start this one.
Working with pictures in cells is not useable until this issue is fixed. Is "formatting" the right 
Subcomponent? Could you please set a target milestone?

Thanks,
Kai
Comment 4 ezza 2008-06-13 01:15:19 UTC
I just reported another issue which is probably related to this one - issue
89544 - about the anchor of a rotated image moving to another cell.
Comment 5 kai_m 2008-06-14 10:54:40 UTC
I aggree with you, that issue 89544 seems to be related this defect. In some cases calc seems to use the 
absolut position to guess the anchored cell.
Comment 6 oc 2008-07-18 09:11:48 UTC
This is a duplicate of #i8303 (same technical reason)

*** This issue has been marked as a duplicate of 8303 ***
Comment 7 oc 2008-07-18 09:12:32 UTC
closed as duplicate