Issue 86030

Summary: Impress crashes when slide show invoked inside xnest
Product: Impress Reporter: gkuenning <geoff>
Component: viewingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, p9w.vu.31122010
Version: OOo 2.3.1   
Target Milestone: ---   
Hardware: Other   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description gkuenning 2008-02-12 06:07:34 UTC
Ooimpress crashes (segfault?) when invoked inside an Xnest server.  Observed on
SuSE Linux 10.3.  Reproduce by:

Xnest -geometry 1024x768+0+0 :1 &
DISPLAY=:1 ooffice {any-presentation-file}

Impress will come up just fine inside the Xnest server; however, when you invoke
a slide show (e.g., via F5) it will immediately crash.  The problem doesn't seem
to depend on the presentation file or format; I also reproduced it by invoking
ooimpress with no arguments and creating a plain 1-slide test presentation.  It
also doesn't seem to depend on the xnest size; I tried several sizes.

The bug is unfortunate because Impress also doesn't provide a way to control the
size of its presentation window.  I can resize my display to match the projector
resolution, but Impress still insists on displaying in the virtual presentation
size.  Xnest would be a perfect way to fool Impress into using the size I
choose, except for this bug.
Comment 1 hayepaul 2008-05-31 18:08:41 UTC
The defect is easy to reproduce. A second defect is also included in the second
paragraph.

Comment 2 wolframgarten 2008-09-05 12:47:40 UTC
Reassigned.
Comment 3 p9w.vu.31122010 2009-07-30 22:37:10 UTC
With m52 Xnext crashes reproducibly when just trying to create a new presentation.

Confirming.
Comment 4 p9w.vu.31122010 2009-07-30 22:38:22 UTC
But oddly the office keeps running in the background and needs to be killed.