Issue 86146

Summary: ease adding R² value with an equation
Product: General Reporter: dudson <petertrypsteen>
Component: chartAssignee: sgautier.ooo
Status: CLOSED FIXED QA Contact: issues <issues.openoffice.org>
Severity: trivial    
Priority: P3 CC: IngridvdM, issues
Version: OOo 3.3 or olderKeywords: usability
Target Milestone: ---   
Hardware: All   
OS: All   
URL: http://specs.openoffice.org/chart/ChartContextMenu.odt
Issue Type: ENHANCEMENT Latest Confirmation on: ---
Developer Difficulty: ---
Attachments:
Description Flags
Just an ods file with a graph and trendlines to test this.
none
TCS Chart Context Menu none

Description dudson 2008-02-16 11:20:43 UTC
Like the title says make also an place in the context menu that appears when
right-clicking on an trendline with Insert "R² and equation".

When doing something for school, we must always add the equation and the R² to
the graph. 
A button to do this fast would come in handy and save time.

(Okay it's two or three seconds but if you count all those seconds of all the
people on the planet who are using OOo, then mankind could be using more than 10
hours more.)
Comment 1 dudson 2008-02-16 11:21:34 UTC
Created attachment 51543 [details]
Just an ods file with a graph and trendlines to test this.
Comment 2 kla 2008-02-18 12:22:44 UTC
Hi Bjoern,
one for you.
Comment 3 IngridvdM 2008-04-03 19:19:13 UTC
I confirm that the workflow could be better. As an alternative solution I could
imagine that that the properties dialog of the equation opens up immediately
when inserting a equation, where you than should be allowed to enable or disable
R2 directly and make other changes like precision of the numbers for example.
Comment 4 IngridvdM 2008-04-03 19:21:02 UTC
*** Issue 86134 has been marked as a duplicate of this issue. ***
Comment 5 dudson 2008-05-06 19:55:12 UTC
That will be a relief and provide a better workflow, thanks.
Comment 6 IngridvdM 2008-07-03 11:40:00 UTC
change owner
Comment 7 IngridvdM 2009-08-07 17:01:19 UTC
The context menu was reworked completely within CWS chartuseability01.
All details can be found in the specification:
http://specs.openoffice.org/chart/ChartContextMenu.odt

For this issue a new entry 'Insert R2' is offered in the context menu of an
equation in case R2 was not added so far. Otherwise 'Delete R2' is offered.
In the context menu of a trend line a new entry is offered 'Insert R² and Trend
Line Equation'
in case no equation was added so far.
Comment 8 IngridvdM 2009-08-26 13:45:01 UTC
Sophie, please verify this enhancement in CWS chartuseability01.
Load the attached example document, select e.g. the equation f(x)=0,2x-1,1 and
open the context menu. There should be an entry 'Insert R2". After the R-square
value was added there should be an entry 'Delete R2".
The complete list of entries for the context menu is given in the specification:
http://specs.openoffice.org/chart/ChartContextMenu.odt
Thanks! Ingrid
Comment 9 sgautier.ooo 2009-09-08 09:17:13 UTC
Verified in CWS chartuseability01
Comment 10 sgautier.ooo 2009-09-08 15:22:13 UTC
Attaching TCS Chart Context Menu - Sophie
Comment 11 sgautier.ooo 2009-09-08 15:22:54 UTC
Created attachment 64617 [details]
TCS Chart Context Menu
Comment 12 sgautier.ooo 2009-10-22 15:41:42 UTC
Verified in OOO320m2 - Closing - Sophie