Issue 86791

Summary: Problem with draging fields in datapilot after changing sourcerange
Product: Calc Reporter: oc
Component: codeAssignee: oc
Status: CLOSED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: issues, kyoshida, stefan.weigel
Version: 680m247   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 23658    
Attachments:
Description Flags
test document none

Description oc 2008-03-07 12:28:44 UTC
This problem does only occur in cws_datapilotrange

- Open attached bugdoc, select cell D31 and open datapilot (kontextmenu - start). 
- Press 'More' button to show options
- Change 'Selection from to $Sheet2.$A$3:$F$21 via rangechooser
- Drag '2006 2007 2008' to the 'Data Area' => one of them could not be draged.
Comment 1 Mechtilde 2009-01-03 14:09:30 UTC
this issue is the reason why the CWS datapilotrange can't be integrated
Comment 2 oc 2009-01-05 15:25:24 UTC
reassigned to kohei
Comment 3 Stefan Weigel 2009-02-14 21:32:39 UTC
Please attach the bugdoc mentioned in the bug description! Thanks.
Comment 4 kyoshida 2009-04-13 18:02:46 UTC
started.
Comment 5 kyoshida 2009-04-13 18:04:08 UTC
@oc: yea, the bug doc appears to be missing.  Could you attach it to the issue?
 Thanks!
Comment 6 kyoshida 2009-04-13 18:18:09 UTC
Ah, I sort of reproduced this.  I'll attach my test document and steps to
reproduce it.
Comment 7 kyoshida 2009-04-13 18:18:45 UTC
Created attachment 61532 [details]
test document
Comment 8 kyoshida 2009-04-13 18:21:54 UTC
With the attached document opened, do

1) Right-click on the data pilot table and select Start.
2) Click More to expand the dialog.
3) Change the data range to $Sheet2.$A$1:$D$5.  At this point, all field buttons
have been reset.
4) Drag G1 to Row field.
5) Drag G2 to Row field.

But the G2 button does not appear in the Row Field box even after dragging it
in.  The funny thing is, when you click OK to dismiss the dialog, the G2 is there.
Comment 9 kyoshida 2009-04-13 21:06:41 UTC
fixed it in datapilotrange cws.  The reason for this weird drag-n-drop issue was
because the arrays that keep track of each field's members were not flushed
properly after the source range change.  Once I flushed them, the drag-n-drop
started working properly again.
Comment 10 kyoshida 2009-04-14 14:32:46 UTC
re-assigning to oc for QA.
Comment 11 oc 2009-05-14 13:59:18 UTC
verified in internal build cws_datapilotrange
Comment 12 Stefan Weigel 2009-08-31 13:53:37 UTC
Verified in DEV300m56.
Comment 13 Stefan Weigel 2009-08-31 13:55:09 UTC
Closing.

Please note issue #104654