Issue 86924

Summary: some icons not updated on a icon theme change
Product: General Reporter: caolanm
Component: codeAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: ace_dent, carsten.driesner, issues, kendy
Version: DEV300m1   
Target Milestone: OOo 3.0   
Hardware: All   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
patch to fix none

Description caolanm 2008-03-11 14:15:57 UTC
Some icons don't change on an icon theme change until a restart.

a) the icons in the vanilla file picker
b) the icons in the first drop down list on the icon menu bar, i.e. the one that
says "text document", "presentation" etc.

To reproduce, start OOo, drop down the list of b) and do a file open for a) and
then change the icon theme to high contrast and revisit them.

Patch attached to fix
Comment 1 caolanm 2008-03-11 14:16:18 UTC
Created attachment 52030 [details]
patch to fix
Comment 2 caolanm 2008-03-11 14:17:02 UTC
not certain that the mnuitem fix is needed, but its the same pattern as the
tbxctrl one which was needed
Comment 3 ace_dent 2008-03-12 10:30:47 UTC
Hi

I'm guessing your patch will fix: Issue 60787 ?...
There area also some related problems (just for info):
Message box images not updated - Issue 60788
Quickstarter 'My Documents' with wrong icons - Issue 60789

Cheers
Andrew
Comment 4 caolanm 2008-03-12 10:49:55 UTC
Wasn't aware of the other issues, but yes the "new" dropdown in issue 60787 is
definitely fixed by this patch, so 60787 looks like it can be made a duplicate
of this (duping towards the issue with a patch). I don't know about the other
two though, that'd need to be checked with this patch in place to see if they
are using the same underlying classes touched here and will magically get fixed,
or if there are some other remaining locations that need to drop their cached
images on a theme change.
Comment 5 Mathias_Bauer 2008-03-12 11:10:53 UTC
Thanks for the patch!
Carsten, please take over.
Comment 6 Mathias_Bauer 2008-03-12 11:13:05 UTC
*** Issue 60787 has been marked as a duplicate of this issue. ***
Comment 7 carsten.driesner 2008-03-12 18:15:51 UTC
cd: Thanks for the patch Caolan. 

cd: Changed platform to "All" as this patch is not platform dependent.

cd->pb: Please take over. I am not able to check the patch carefully as I will
be in vacation from tomorrow on. I just took a quick look and found no problems.
The patch looks good to me.
Comment 8 Mathias_Bauer 2008-03-13 10:41:27 UTC
Please don't forget to check the status of the other mentioned issues here after
the patch has been applied.
Comment 9 pb 2008-03-31 07:20:35 UTC
pb: I take over.
Comment 10 pb 2008-04-07 12:49:46 UTC
pb: patch integrated in cws fwk86:
Files changed:
/svtools/source/misc/imagemgr.cxx 1.50.30.1
/sfx2/inc/sfx2/mnuitem.hxx 1.2.282.1
/sfx2/inc/sfx2/tbxctrl.hxx 1.2.282.1
/sfx2/source/menu/mnuitem.cxx 1.21.82.1
/sfx2/source/toolbox/tbxitem.cxx 1.67.216.1
Comment 11 pb 2008-04-08 05:34:42 UTC
pb: issue 60787 and issue 60789 are fixed with this patch but not issue 60788.
Comment 12 pb 2008-04-22 09:48:49 UTC
pb -> tm: please verify. Thx.
Comment 13 pb 2008-04-22 09:53:39 UTC
pb -> tm: this patch doesn't fix that the images of the submenu of the "New"
menu entry don't change but it fixes that images of the menu of the "New"
toolbar button change. The "New" menu is another implementation.
Comment 14 thorsten.martens 2008-05-09 07:26:49 UTC
checked and verified in cws fwk86 -> OK
Comment 15 caolanm 2008-05-19 12:12:06 UTC
seen in DEV300_m13
Comment 16 ooo 2008-06-02 11:12:32 UTC
*** Issue 88249 has been marked as a duplicate of this issue. ***