Issue 86987

Summary: Problem BASIC I/O when opening writer at first time after modifying installation script
Product: General Reporter: myx <myx>
Component: codeAssignee: Olaf Felka <olaf-openoffice>
Status: CLOSED OBSOLETE QA Contact:
Severity: Trivial    
Priority: P3 CC: ab, carsten.driesner, elish, ingo.schmidt-rosbiegal, issues, leiflodahl, michael.cziebalski
Version: OOo 2.3.1Keywords: needhelp
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description myx 2008-03-13 10:50:39 UTC
Hello,

I'have to deploy openoffice 2.3.1 on a lot of machines and i use a windows 2003
server in order to.
I've modified openofficeorg2.3.1.msi with orca, see change here :
     'property' table :
            INSTALLLEVEL at 300
            SELECT WORD at 1
            SELECT EXCEL at 1
            SELECT POWERPOINT at 1

I've installed my package with msiexec /quiet /i openoffice231org.msi : OK
I've changed Setup.xcu, see lines changed below (in 'Office' section) :

     <prop oor:name="ooSetupInstCompleted">
       <value>true</value>
     </prop>
     <prop oor:name="ooSetupShowIntro">
       <value>true</value>
     </prop>
     <prop oor:name="LicenseAcceptDate" oor:type="xs:string">
       <value>2008-03-12T11:58:44</value>
     </prop>
     <prop oor:name="FirstStartWizardCompleted" oor:type="xs:boolean">
       <value>true</value>
     </prop>

After it, when i launch writer for first time, i've an error message :
      General error I/O, can't launch script.xli
                                      script.xlc
                                      dialog.xli
                                      dialog.xlc

Thanks to help me please.
Comment 1 michael.ruess 2008-03-13 14:28:28 UTC
Reassigned to "Installation".
Comment 2 Olaf Felka 2008-04-30 13:00:52 UTC
@ cd &  is: Are these changes to the msi file and setup.xcu valid?
@ myx: Maybe you should also refer to 'users@openoffice.org' for help. With an
unmodified OOo you won't get such an error.
Comment 3 carsten.driesner 2008-04-30 13:41:42 UTC
Set ab on CC.

cd->ab: The error message mentions that some Basic files cannot be "launched".
Currently I don't know why this message occurs as no pathes have been changed.
May be you can give us more information.
Comment 4 aladdin2k7 2008-04-30 13:44:56 UTC
Be carefull by modifying parameters from the "share".

Update 
<prop oor:name="ooSetupInstCompleted">
       <value>true</value>
</prop>

to

<prop oor:name="ooSetupInstCompleted">
     <value>false</value>
</prop>

and LicenseAcceptDate must be a date after the one you make your deployment
otherwise OOo will show the popup.

From Setup.xcs :
"The xsd:datetime (YYYY-MM-DDTHH:MM:SS) on which the user has accepted the
license. If the current installation has a license that is newer then this date,
the license has to be accepted again."
Comment 5 ab 2008-04-30 14:12:41 UTC
Strange. I don't know what could be the reason. The error messages
differ from the error messages that occur if e.g. a script.xlc file is
completely missing. I don't know this "can't launch" message at all.
The .xli extension belong to a deprecated file format and I have no
idea why it should be accessed in this situation.
Comment 6 ingo.schmidt-rosbiegal 2008-04-30 16:46:02 UTC
The changes in the msi file are valid, they are not problematic. I do not know,
if the changes in setup.xcu can cause such problems. I tested this changes in
setup.xcu with an installed OOo 2.4 and everything worked without problems (but
the First Start Wizard appeared). 
Comment 7 mci 2008-05-13 19:41:41 UTC
added mci to CC

Hi all,

I saw this problem while I tried to prevent the users seeing the registration
wizard after updating OOo2.2 to OOo2.4, too...

I got this error only by trying to open a document which contained macros . 

ATTENTION:
   The account I used did not have a user configuration from an older OOo (e.g.
OOo2.2.1)!!!
This error didn't appear if there was a valid user configuration in <system
drive>:\Documents and Settings\<username>\Application Data

maybe this helps...

Work around: copy a valid user configuration into the "Application Data"-Path of
that user... In my case that helped...
Comment 8 leiflodahl 2009-08-04 14:05:08 UTC
Added myself to cc. 
Comment 9 Olaf Felka 2010-01-06 12:56:41 UTC
This issue is pretty old now. is this still valid in OOo 3.2 RC1? If yes who of
the (CCed) developers will take over?
Comment 10 carsten.driesner 2010-01-06 13:23:03 UTC
cd->of: From my point of view ab should look at this issue. May be he needs some
help from my side. Could you reproduce this issue in the latest version?
Comment 11 Rob Weir 2013-02-02 02:55:11 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 12 Rob Weir 2013-04-05 14:18:16 UTC
Removed "needmoreinfo" keyword
Comment 13 Olaf Felka 2014-03-31 15:09:53 UTC
As we have no further feedback for years now I think that issue can be closed.
Comment 14 Olaf Felka 2014-03-31 15:10:08 UTC
.