Issue 87124

Summary: File/Open dialog invoked from the Start Module silently ignores multiple-selection
Product: General Reporter: Frank Schönheit <frank.schoenheit>
Component: uiAssignee: Frank Schönheit <frank.schoenheit>
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues, olaf-openoffice, philipp.lohmann
Version: DEV300m3Keywords: usability
Target Milestone: OOo 3.0   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot for issue #87124 (no file types in file picker) none

Description Frank Schönheit 2008-03-17 12:17:06 UTC
- in a running OOo, close all documents, so that only the Start Module
  is open
- press the "Open an existing document" button
=> the file picker opens
- browse to some arbitrary location
- and select at least two files
- press "Open"
=> the dialog is closed, but nothing happens

This is different to when you invoke the file picker from the menu (File/Open),
where multi selection is supported, too, and works as expected.
Comment 1 Frank Schönheit 2008-03-17 12:17:57 UTC
adding keyword "usability", targeting to 3.0.
Comment 2 philipp.lohmann 2008-03-17 17:46:39 UTC
fixed in CWS vcl87
Comment 3 philipp.lohmann 2008-03-18 15:31:12 UTC
pl->fs: thanks for verifying since OF is on vacation
Comment 4 Frank Schönheit 2008-03-18 16:02:17 UTC
looks good in CWS vcl87
Comment 5 philipp.lohmann 2008-04-02 12:10:55 UTC
*** Issue 87719 has been marked as a duplicate of this issue. ***
Comment 6 esperantisto 2008-04-24 09:57:24 UTC
Since the issue 87719 is marked as duplicate to this issue, I report here.

When I call the file open dialog from the 'Welcome to OOo-dev' start screen, I
can't see any file filter for file types, as reported for 87719. The issue 87719
is closed and this issue 87124 is fixed, both issues related to DEV300m3, but
the problem persists in DEV300m10 / Windows XP.
Comment 7 Olaf Felka 2008-04-24 10:46:33 UTC
I can't confirm. My DEV300_m10 shows all file types in file picker when started
in Start Center.
Comment 8 esperantisto 2008-04-24 12:21:01 UTC
OK, here's a screenshot: no file types at all. Note, if I create an empty
document, such a problem does not appear.
Comment 9 esperantisto 2008-04-24 12:22:33 UTC
Created attachment 53166 [details]
Screenshot for issue #87124 (no file types in file picker)
Comment 10 esperantisto 2008-04-24 12:26:34 UTC
I've also tried to switch to OOo open/save dialogs instead of system, but the
problem persists in that case too.
Comment 11 Olaf Felka 2008-04-24 12:55:01 UTC
Have you removed you're User Settinngs in '..\Application Data\'?
Comment 12 esperantisto 2008-04-24 13:14:45 UTC
I've copied to OOo3 directory my user settings from OOo2. Does that matter? Do I
need to remove/correct something?
Comment 13 Olaf Felka 2008-04-24 14:26:04 UTC
It might matter. Just rename your OOo 3.x user folder and retry.
Comment 14 esperantisto 2008-04-24 14:43:12 UTC
I've tried that (renamed my user directory and let OOo create a new one with the
default settings), but it did not help: still no file types in the picker.
Comment 15 Olaf Felka 2008-04-25 09:25:24 UTC
Somebody has an idea what goes wrong here?
Comment 16 thorsten.ziehm 2009-07-20 15:55:48 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues