Issue 87351

Summary: Printer default settings consistently overwritten (or ignored)
Product: General Reporter: heavylight <ghuber>
Component: codeAssignee: h.ilter
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: florian.bi, issues, s354428
Version: OOo 2.3   
Target Milestone: ---   
Hardware: PC (x86_64)   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
printer setup for C10 encelopes. none

Description heavylight 2008-03-23 16:42:35 UTC
When attempting to print using the default printer settings (printing an
envelope from the manual feed tray in this case), OO fails to properly accept
the "Printer Default" paper source and the "paper tray from printer settings"
printer option. If I export the envelope as PDF and use Acrobat to print it,
Acrobat does use the printer defaults and prints the envelope properly. I have
not been able to define any setting within the OO print section(s) that will
allow a document to be printed with printer defaults.

This was fixed a few releases ago, but seems to be broken again.


Steps to reproduce
1) define (through CUPS) a printer that draws C10 envelopes from the manual feed
tray
2) create and populate a C10 document (address the letter) with OO Writer
3) Select File->Print->General => "envelope printer created in step 1"
4) Select File->Print->PageSetup->paper type => "Envelope"
5) Select File->Print->PageSetup->paper source => "Printer Default"
6) Select File->Print->Options->Other->"paper tray from printer settings"
7) Select Print (to send job to printer)
Comment 1 heavylight 2008-03-23 16:59:09 UTC
Created attachment 52252 [details]
printer setup for C10 encelopes.
Comment 2 greghuber 2009-02-12 16:44:16 UTC
I am having the same problem with release 3.0.1
No matter how I configure the page or printer, It always tries to print to tray
1. If I save the envelope as PDF, I can use the same CUPS printer and it prints
to the manual feed tray.
Comment 3 Olaf Felka 2009-07-15 10:44:52 UTC
@ hi: Please have a look
Comment 4 ahung 2009-11-15 11:50:54 UTC
I have the same problem under windows xpsp3 for OOO310m19 build 9420
Default printer setting on the system was totally ignored / overrided by the
document which is a hassle because I need to set printer for each and every file.
Comment 5 fbircher 2010-08-05 21:22:08 UTC
Similar problem as Issue 110370 ?
Comment 6 h.ilter 2010-10-19 15:11:20 UTC
Seen good with OOO330m5 where also Issue 110370 is integrated
Comment 7 h.ilter 2010-10-19 15:11:43 UTC
Closed