Issue 87555

Summary: Newly loaded Excel or PowerPoint file considered as modified - approved
Product: General Reporter: bmarcelly <marcelly.bernard>
Component: uiAssignee: christian.guenther
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues, kamataki, kpalagin, masaya.k
Version: OOo 2.4.0Keywords: regression
Target Milestone: OOo 2.4.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 88258    

Description bmarcelly 2008-03-28 13:35:04 UTC
Open any Excel 97 or PowerPoint 97 file.
The "save" icon is enabled. If you close the document the warning message says that 
the document has  not been saved.

Same problem with a PowerPoint or Excel document created by OpenOffice.

Regression found by several users on 2.4.0 RC6 and 2.4.0 final
<http://www.oooforum.org/forum/viewtopic.phtml?t=69882&highlight=>
<http://user.services.openoffice.org/en/forum/viewtopic.php?f=5&t=3924>
Comment 1 bmarcelly 2008-03-28 13:36:26 UTC
Setting regression keyword :-(
Comment 2 billp 2008-03-29 17:40:57 UTC
*** Issue 87555 has been confirmed by votes. ***
Comment 3 h1onooo 2008-04-08 13:43:38 UTC
confirming on WinXP SP2 with OOo 2.4.0 german even after:
- complete deinstall and removing of program directory, then new install
- complete new profile in %appdata% (current OpenOffice.org2 dir renamed)

all xls worksheets on my system, created with excel 97 or previous OOo versions,
(presumalby all in excel 97 format) open as modified except when having the
read-only attribute set: then they open read-only.
Comment 4 christian.guenther 2008-04-11 17:26:29 UTC
*** Issue 88148 has been marked as a duplicate of this issue. ***
Comment 5 kpalagin 2008-04-11 19:08:36 UTC
Also see http://qa.openoffice.org/issues/show_bug.cgi?id=88083 targeted for 
2.4.1.
Comment 6 jjmckenzie 2008-04-12 03:36:55 UTC
*** Issue 88083 has been marked as a duplicate of this issue. ***
Comment 7 jjmckenzie 2008-04-12 03:40:48 UTC
Confirmed that this can be duplicated on the Mac X11 version of 2.4.  This is
not a showstopper but should be fixed for 2.4.1 and 3.0 as this is definitely a
regression from 2.3.1 actions.  Saving an .xls to .ods and opening the .ods file
did not show a need for saving on a new file.  However, saving a modified .ods
file as .xls and then opening the .xls file did.
James McKenzie
Comment 8 brucehohl 2008-04-15 11:15:30 UTC
An accountant's plea for a quick fix to my favorite spreadsheet program: This
issue degrades the user experience with OpenOffice by a fair amount if like me
you are in an environment where many shared documents are opened and closed
throughout the day often only for viewing. This bug also reflects poorly on
OpenOffice since it is so obviously incorrect to report a just opened xls file
as modified.
Comment 9 Uwe Altmann 2008-04-23 10:35:25 UTC
IMHO import of an MS Office into OOo document always is a modification, because
we actually do not (and perhaps never will) have 100% import filters. So you may
loose information on opening such documents in OOo (i.e. some effects in
Powerpoint) - and not notice this as modification of the original document??? 
At least the quality of the import filter should be considered.
Comment 10 bmarcelly 2008-04-23 12:27:23 UTC
@ uwealtmann : this issue describes a bug, it is not a new feature. It concerns Excel 
and PowerPoint, but not Word.

Open a new Calc document.
Write Hello in a cell.
Save it as MS Excel 97. Close.
Reopen it : it is considered as already modified.
Where is the loss of information?
Comment 11 thorsten.martens 2008-04-23 13:21:39 UTC
TM->SJ: please have a look, thanks
Comment 12 wolframgarten 2008-04-28 12:54:25 UTC
There will be an automated testcase for this.
Comment 13 uwe.luebbers 2008-04-29 13:21:00 UTC
added "approved" to the title, because it will be easier to work with the 2.4.1 meta issue 
during release status meetings.
Comment 14 sven.jacobi 2008-04-30 15:46:28 UTC
accepted
Comment 15 sven.jacobi 2008-05-05 17:59:56 UTC
This issue has been fixed now in cws[sjfixes04]
Comment 16 sven.jacobi 2008-05-05 18:00:48 UTC
sj->cgu: please verify
Comment 17 christian.guenther 2008-05-07 16:27:23 UTC
CGU: Verified in cws sjfixes04
Comment 18 rblevin 2008-05-27 20:05:19 UTC
This bug is not dependant on newly loading Excel or PowerPoint files. I have
native Calc ODS files (i.e., created from scratch in Calc) that exhibit this
behavior.

I can open the file, immediately close it, and Calc asks me if I would like to
save changes.

Interestingly, not _all_ ODS files do this. I'm trying to determine what
triggers this.

No macros in any of the files.
Comment 19 christian.guenther 2008-06-30 14:06:39 UTC
CGU: Integrated in dev300m19