Issue 87607

Summary: Customize event window does not show assigned actions in 1.1 document
Product: General Reporter: bmarcelly <marcelly.bernard>
Component: uiAssignee: AOO issues mailing list <issues>
Status: REOPENED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: elish, issues, marcelly.bernard
Version: OOo 2.4.0   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
OpenOffice text document executing macros at load and closure.
none
Snapshot of what is displayed on Windows XP none

Description bmarcelly 2008-03-30 14:09:28 UTC
This problem appears also with OOo 2.3.1.

1 - Open a OOo 1.1.x document which contains macros assigned to a document event.
2 - Open Menu Tools > Customize > Events tab
There is no assigned action on any event.

On my computer I have assigned an icon to the Basic organizer and I see an icon on 
these event(s) but no visible action.
Even if you see the icon, you don't know which macro is called by the event so you 
can't really understand how the program works (typical case: you have opened an old 
document created by someone else).
Worse, if you convert the document to ODF, you still cannot see the assigned 
actions(s).

There is a possible security threat : you receive a document (even an ODF doc, as 
said above), open it outside a trusted file location to have a quick inspection of 
its macros. You don't see assignment at document opening or closure and let the 
document be distributed in your company.
Comment 1 bmarcelly 2008-03-30 14:11:13 UTC
Created attachment 52371 [details]
OpenOffice text document executing macros at load and closure.
Comment 2 jjmckenzie 2008-04-12 04:03:27 UTC
With the Mac X11 version, events appear on Open Document and Close Document. 
The Open Document event was to open a dialog box with a message and the "OK" button.
Closing the document resulted in another dialog box with message and the "OK"
button.  Clicking on the button allowed the document to close.  Remember, with
default macro security of high, all macros are automatically disabled except
from a trusted source.  Could not duplicate reported problem.
James McKenzie

Comment 3 bmarcelly 2008-04-12 12:34:31 UTC
Created attachment 52778 [details]
Snapshot of what is displayed on Windows XP
Comment 4 Olaf Felka 2010-08-20 12:09:27 UTC
Any news on OOo 3.2.1?
Comment 5 hans_werner67 2011-03-28 11:52:21 UTC
Assign to new default-assignee
Comment 6 Edwin Sharp 2014-02-05 14:05:50 UTC
Assigned actions are visible
AOO410m1(Build:9750)  -  Rev. 1562493
Rev.1562493
Win 7
Comment 7 bmarcelly 2014-08-07 07:18:42 UTC
Windows 7, Apache OpenOffice 4.1.1 RC1, fresh user profile.

Still the same problem with attachment 52371 [details] :
Opening Menu Tools > Customize > Events tab, I still see the same image as attachment 52778 [details].


Remember that old OpenOffice has a different script URL than current OpenOffice. As example this is the structure of OnLoad event from the provided document:

MacroName   "Standard.Module1.Hello" 
EventType   "StarBasic" 
Library     "document" 
Script      "macro://./Standard.Module1.Hello()" 

Here is the same Event from an equivalent odt document:

EventType   "Script"
Script      "vnd.sun.star.script:Standard.Module1.Hello?language=Basic&location=document"