Issue 88132

Summary: Picture and Drawing toolbars inconsisteny for "Insert From File" item.
Product: Writer Reporter: fenixproductions <fenixproductions>
Component: editingAssignee: AOO issues mailing list <issues>
Status: CLOSED DUPLICATE QA Contact:
Severity: Trivial    
Priority: P3 CC: cno, issues, rb.henschel
Version: OOo 2.4.0   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description fenixproductions 2008-04-10 12:46:34 UTC
When user switch on Image and Drawing toolbars visibility, he can see on each 
of them an "square-circle-triangle" icon. The hint for this item says: "From 
File."
When it is clicked "Open file" dialog is shown and user can choose image to put 
into document BUT if document already contains a graphic object which is 
selected, clicking on it gives properties dialog.

This one can mislead user because of tooltip saying nothing about properties, 
so user can expect that he will have the possibility to change selected picture 
to another one.

It could be changed in two ways:
- implement "From File" functionality for all of the time,
- change tooltip AND icon dynamically, depending on selection.

Please remember that first solution gives no possibiity to see item's 
properties via toolbar.
Comment 1 michael.ruess 2008-04-10 13:22:08 UTC
MRU->FL: I'm quite sure, that this issue already exists, but I could not find.
This topic has been discussed  several times without a result. It is not quite
consistent, that the Picture or Frame properties dialog is opened when a graphic
or frame is selected and the Insert.Picture.From file or Insert.Frame command is
called from menu/toolbar.
It should be more intuitively when the selected item is replaced by the new one
in this case.
Comment 2 cno 2008-04-11 22:19:44 UTC
pls note issue 88164, about the same icon
Comment 3 Regina Henschel 2013-06-17 17:27:36 UTC
No need for several issues about the same topic.

*** This issue has been marked as a duplicate of issue 12891 ***