Issue 88365

Summary: periods in Calc column headings break mail merge and labels creation
Product: Base Reporter: samix <hs.samix>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: cno, issues
Version: OOo 2.4.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot showing what is talked about none

Description samix 2008-04-16 22:42:50 UTC
Hello,

Just wanted to share the experience that the presence of any periods in the
title row of a spreadsheet messes up the mail merge fields when a database
source is created from the said spreadsheet. For example, "P.C." title of a
column creates empty fields in mail merge ("<>" is shown) but changing it to
"Postal Code" fixes it. It appears that since periods are used as separators in
the address book fields, the periods in the title row may be messing things up.

Further, the problem manifests itself in weird ways if I drag and drop a field
from a database source into the first label (from the database sources, obtained
by pressing F4). By dragging fields this way at least does not give the empty
fields <>. This happened while I was printing labels. Initially, all the labels
turned out to be the same. I then tried to delete the fields from the first
label so that only the fields with no periods remained and synchronized other
labels, and then added each field from the address source (got by pressing F4)
by clicking on the field and dragging and dropping it. As long as I included
fields with no periods, everything worked, but as soon as I included fields with
periods, the output data seemed to have been shifted by one cell (the first cell
of the columns with headings with period was missing).

This was on OOo 2.4 on Windows as well on Debian Sid.

thanks,
->HS
Comment 1 noop 2008-04-16 23:41:56 UTC
System: Linux - Ubuntu 7.10 (Gutsy)
Existing OOO: 
[Version]
AllLanguages=en-US
buildid=680m12(Build:9286)
ExtensionUpdateURL=http://updateext.services.openoffice.org/ProductUpdateService/check.Update
OOOBaseVersion=2.4
ProductBuildid=9286
ProductMajor=680
ProductMinor=12
ProductPatch=
ProductSource=OOH680
UpdateID=OpenOffice.org_2_en-US

I can confirm using labels:

I created a new label document (File|New|Labels) and found that if I
use "Zip" in the Calc column heading the <zip> field appears properly. However,
if I use "P.C." in the Calc column heading, I end up with an empty <> field.
Comment 2 christoph.lukasiak 2008-09-01 14:49:40 UTC
change owner
Comment 3 safway 2008-12-02 17:11:26 UTC
I can also confirm this using OO.o version 3.0.  The problem is NOT manifest
when creating a "normal" document using File | New | Text Document.  It IS
manifest when creating labels using File | New | Labels.  See attachment screenshot.

When creating a label, the dragging of the field from the database source works
but the wizard doesn't.
Comment 4 safway 2008-12-02 17:13:05 UTC
Created attachment 58453 [details]
Screenshot showing what is talked about
Comment 5 christoph.lukasiak 2009-04-08 14:50:44 UTC
back into pool because of vacation
Comment 6 cno 2009-07-02 21:03:50 UTC
I can confirm the issue.
Not a P2 however.
And maybe even an enhancement rather then a defect?
Comment 7 cno 2009-07-10 10:52:41 UTC
or could something be found in on of the specs?
http://dba.openoffice.org/specifications/index.html