Issue 89207

Summary: On startup, complains it can't find some WebWizard files
Product: General Reporter: roadkills_r_us <meo>
Component: wwwAssignee: ab
Status: CLOSED DUPLICATE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P4 CC: issues
Version: OOo 3.0 Beta   
Target Milestone: AOO Later   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 81913    

Description roadkills_r_us 2008-05-08 22:50:34 UTC
Whenever I start OOo 3beta, I get two popups (one after the other) complaining
it can't find files.  I get this whether I'm starting the app with a filename to
edit or not.

Error loading BASIC of document
file:///usr/lib/ooo-1.1/share/basic/WebWiazrd/script.xlb/:
General Error.
General input/output error.
[OK]

Error loading BASIC of document
file:///usr/lib/ooo-1.1/share/basic/WebWiazrd/dialog.xlb/:
General Error.
General input/output error.
[OK]

This is from my home system.  I have OOo3b installed at work and get the same
thing, with a slightly different path.

I haven't done anything webish, so I have no idea whether this impacts anything
that matters; it just consistently requires me to click [OK] twice any time I
open OOo3b.

I have used a couple of versions of OOo2 since using OOo1x.  I always tell the
new version to use settings from my old version.

I looked through my personal config files and removed the lines containing those
paths from .openoffice.org3/user/basic/script.xlc and
.openoffice.org3/user/basic/dialog.xlc and the behavior ceased.  But the average
newbie Linux user who does everything from a GUI won't know to do that.
Comment 1 Olaf Felka 2008-05-09 09:30:42 UTC
looks like 87871
Comment 2 ab 2008-05-09 14:07:39 UTC
I haven't found the issue idea yet, but I think this is a known problem
related to the reuse of the old settings. Unfortunately the real bug is
located in one of the 1.x versions and somehow old script/dialog.xlc
files made it into your current installation.

The WebWizard used to be implemented in Basic but was migrated to Java.
So the Basic libraries became obsolete, but of course are still there
in old script/dialog.xlc files. The error messages don't cause further
problems and changing your script/dialog.xlc files was the right thing
to do. I doubt that much effort is justified to fix this problem, but
I keep it as reference.

STARTED, OOo later
Comment 3 stevanwhite 2008-09-12 14:20:03 UTC
See notes at
http://qa.openoffice.org/issues/show_bug.cgi?id=59890

I highly recommend fixing this.  It is making you look bad.
Comment 4 ab 2008-09-15 08:51:13 UTC
ab->of: Not really related to i87871, this problem is much older

It makes no sense to keep all similar issues active,
setting this one duplicate to i59890, see my comment there.


*** This issue has been marked as a duplicate of 59890 ***
Comment 5 Mechtilde 2008-11-05 21:21:56 UTC
close the duplicate