Issue 89232

Summary: Fill operations should not touch filtered rows.
Product: Calc Reporter: ooo
Component: editingAssignee: kla <thomas.klarhoefer>
Status: VERIFIED FIXED QA Contact: issues@sc <issues>
Severity: Trivial    
Priority: P3 CC: aladdin, alexander.m.fritz, arno, clement.pillias, cmoulin, cno, darabos.daniel, dejan.rodiger, de_logics, edb_s-gene01, franjb68, graham.crookham, hgtoo, issues, jclutterbuck2001, kpalagin, kristjan, marc.galmard, nesshof, norbert.notz, pagalmes.lists, pescetti, peter, raal, riccardo.arzenton, robert.pollak, stefan.weigel, vavra_milan, vitriol_vitriol, yoshimit
Version: DEV300_m10   
Target Milestone: 3.4.0   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description ooo 2008-05-09 13:41:45 UTC
This is a follow-up issue on issue 33851. As discussed for cws 'filteredrows'
there was no time to implement a proper behavior for fill operations on filtered
rows, that should not be touch on such operations.
Comment 1 ooo 2008-05-09 13:49:39 UTC
Targeting 3.x
Comment 2 kpalagin 2008-05-10 09:27:48 UTC
Maybe 3.1?
Comment 3 helenrussian 2008-05-12 12:02:04 UTC
*** Issue 88482 has been marked as a duplicate of this issue. ***
Comment 4 helenrussian 2008-05-12 12:02:54 UTC
*** Issue 88482 has been marked as a duplicate of this issue. ***
Comment 5 niendo 2008-05-13 16:10:41 UTC
Maybe 3.01?
Comment 6 akjacques 2008-06-20 04:25:02 UTC
Greetings

I can't believe this issue was not fixed in 3.0. I have just downloaded 3.0 
after my issue was merged into 33851, and I find that the drag-fill issue still 
remains.

I use auto-filter in almost every spreadsheet I have created and without this 
drag-drop situation being fixed I must revert back to MS excel.

In my opinion, this is the most critical flaw that Open Office Calc has and 
until it is fixed I can neither use it or recommend it.
Comment 7 jclutterbuck 2008-06-20 10:07:14 UTC
Greetings all,

Further to akjacques comments I note it is SIX AND A HALF YEARS!! since I posted
the original Issue 2977 and this still drags on. Because of this I had to
contribute to Bill Gates' billions 4 years ago and buy MS Office for my student
children, I haven't used OO since and do not intend to or recommend it until
this is finally fixed.

JC
Comment 8 kheekien 2008-06-21 04:54:37 UTC
Likewise, if not for this feature, I would have used Calc instead of M$ Office.
 I have been voting and waiting for this feature to be fixed since OO 1.x and
can't believe its not fixed for OO 3.0.

Filtering is one of the most important and powerful features that a spreadsheet
has and this issue literally makes this feature in Calc not useable.
Comment 9 cobologna 2008-07-09 14:28:54 UTC
Hi everybody,
Calc is a great tool, but this defect is a severe problem. I am going to deploy
openoffice on hundreds of clients, several of which are used by administrative
employees. They use filters all the time and this issue will significantly
affect them.

cb
Comment 10 kpalagin 2008-10-17 07:47:59 UTC
Eike,
how this issue is going to proceed? Is it waiting for specification or 
timeslot in your schedule?
Thanks.
WBR,
KP.
Comment 11 ooo 2008-10-17 10:35:36 UTC
Timeslot.
Comment 12 frank 2009-02-19 14:00:35 UTC
*** Issue 99416 has been marked as a duplicate of this issue. ***
Comment 13 ooo 2009-06-17 09:16:15 UTC
*** Issue 101011 has been marked as a duplicate of this issue. ***
Comment 14 jclutterbuck 2009-07-15 09:41:19 UTC
Once again I missed the anniversary back in January of issue 2997 when I first
reported this back in January 2002 - YES 7.5 years ago. I am now using OO on my
new Mac and having just upgraded to 3.1.0 I thought I would check it out again
and made a screen video of the results:

http://www.youtube.com/watch?v=B7ArppPlckA

Why can't anyone at OO understand this is a serious DEFECT and always has been?
Comment 15 jclutterbuck 2009-07-17 08:40:46 UTC
Putting it on YouTube seems to have finally interested the media:
http://www.theregister.co.uk/2009/07/16/openoffice_autofilter_bug_feature/
Comment 16 ooo 2009-07-17 09:36:59 UTC
@jclutterbuck:
For the records: it was issue 2977 and not 2997. Thank you for stirring a "horde
of angry chimps". And thanks Ed Hawley for denying reality, "No one seems to
accept that it's a major problem. Developers say it works as specified," that's
just a lie, why would we have created this issue then?
Comment 17 jclutterbuck 2009-07-17 10:11:37 UTC
Thanks ER for pointing out my mistake in the issue number.

I also refer you to the following from issue 2977

---- Additional comments from jclutterbuck Fri Oct 31 16:22:28 +0000 2003 ----
As can be seen (but not very well) under Issue Activity I originally reported
this as a DEFECT but it was rejected as a WONTFIX as the developer said it
worked as intended!

I reopened it and it was changed back to a P3 ENHANCEMENT. I have changed it
back (twice I think) to a DEFECT and each time it was set to an ENHANCEMENT.

----------------
And 7.5 years later it's still only a P3 enhancement - is this really caring
about it? 
Comment 18 ooo 2009-07-17 11:32:50 UTC
Whatever was said back 6 years ago, the worn-out "works as intended" simply
doesn't hold anymore at least since we opened issue 33851.

For completeness: after issue 2977, that and other issues addressed only some
details, issue 33851 was created to summarize different aspects. Due to the
large amount of controversial discussion in that issue that nobody could follow
anymore we created
http://wiki.services.openoffice.org/wiki/Calc/Drafts/Issue_33851 to come to some
conclusion. A summary of the fixes implemented is available at
https://tools.services.openoffice.org/EIS2/changesmails.EditFeature?Id=4208

As you can see, the only aspect that couldn't be fixed in time is the fill
behavior because it works differently from copy&paste and others.

Nobody says it's not important, just that someone actually has to do it.
Resources are limited, as usual. So if anyone wanted to throw a developer on
this who could contribute he would be more than welcomed.

And now please let's stop discussion here in the issue or we'll end up with just
another lengthy unreadable comment list. Thank you.
Comment 19 Rainer Bielefeld 2009-08-26 06:43:11 UTC
*** Issue 104473 has been marked as a duplicate of this issue. ***
Comment 20 kpalagin 2009-09-10 07:10:41 UTC
Eike,
please consider this issue for 3.3.
Thanks  a lot for your attention.
Comment 21 bodrisch 2010-02-19 12:31:18 UTC
Please, solve this problem ASAP, for 3.3.
Comment 22 flint1975 2010-06-08 20:02:55 UTC
This is very old problem! And very important!
Comment 23 stefanov_sm 2010-07-20 15:43:10 UTC
For the time being before the issue is fixed simply disallow
autofill/propagate/whatever operations when filter is on. Clean and honest. Put
a large notice on the border of a minefield instead of waiting to see who walks
in & what happens to him.
Comment 24 hlerdo 2010-09-11 16:31:01 UTC
Hi,

Although I have been using Calc since SO 2.x times I didn't know about this
problem until 30 mins ago. I never worked extensively with autofilter before
until now. Result: It destroyed about 2 days worth of work and leaves a serious
bad taste in the mouth. And to see that it has been around since 2002 REALLY
aggrevates!! Am I one of those angry chimps now that I read about here
(http://www.theregister.co.uk/2009/07/16/openoffice_autofilter_bug_feature/)?

I like OO, I like the fact that it free even more! But in order to seriously
take off some marketshare from Excel things like this simply mustn't happen!
Please remedy this defect without looking at votes! Most users don't go as far
as this issues tracker!

Thanks!
Comment 25 hlerdo 2010-09-11 17:34:49 UTC
Forgot to mention: OO Version 3.2.1
Comment 26 gigahz 2010-10-05 22:06:06 UTC
I see copy to filtered list works. Now, dragging should too. I won't comment
more cause I see from history this is a very old bug. If only I could do
something to help out.
Comment 27 niklas.nebel 2011-03-09 18:37:15 UTC
Fixed in CWS calc66, based on a patch from the IBM Symphony team. Filtered rows are skipped, and if there are filtered rows, the default is copying instead of incrementing.
Comment 28 ooo 2011-03-11 13:03:42 UTC
Code change reviewed.
Comment 29 niklas.nebel 2011-03-15 14:41:34 UTC
Reassigning to QA for verification.
Comment 30 kla 2011-03-21 14:14:19 UTC
Seen ok in cws calc66 -> verified
Comment 31 ooo 2011-03-28 09:50:01 UTC
*** Issue 114795 has been marked as a duplicate of this issue. ***
Comment 32 ooo 2011-03-28 09:50:55 UTC
*** Issue 117555 has been marked as a duplicate of this issue. ***
Comment 33 niklas.nebel 2011-05-13 12:33:46 UTC
*** Issue 118008 has been marked as a duplicate of this issue. ***
Comment 34 gigahz 2011-05-14 05:11:29 UTC
oh oh oh this sounds so sweet! 

ok, it's been 8 years but if the bug's down than it's really something.

You see, it was very destructive to my spreadsheets.

spread the word, akjacques, jclutterbuck, kheekien  and the rest!

I know this is an unneccesary comment that does nothing to the process :) But why only complain? :) :)
Comment 35 Marcus 2015-03-20 20:28:51 UTC
*** Issue 126193 has been marked as a duplicate of this issue. ***
Comment 36 riccardo.arzenton 2015-03-23 08:29:46 UTC
The problem is still present in OO 411