Issue 8967

Summary: open dialog should invoke txt import wizard when started from spreadsheet
Product: General Reporter: bwlang <brad>
Component: uiAssignee: andreas.schluens
Status: CLOSED WONT_FIX QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P4 CC: azurewraith19, bob-openoffice, issues
Version: OOo 1.0.1   
Target Milestone: AOO Later   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description bwlang 2002-11-04 17:06:35 UTC
I tried to import a tab delimited table this morning...

I created a new spreadsheet instance and went to file:open 
after selecting the document i wanted (data.txt)
i clicked open expecting to see an import dialog asking me about delimiters etc.
instead it just opened in writer.

After trying a few choices of import type i turned to the help file which
instructed me to use the Text CSV type to do the import.  This works fine, but
is non-intuitive (it wansn't a CSV file after all).

I think that the open dialog should have different action based on which
application it is called from.  If I call it from writer i probably want to
import to writer. If I call it from spreadsheet i want to import there, etc.
If this is not possible, selecting the type of file you want to create in the
dialog would be a logical second choice. (ie select file type as spreadsheet)
Comment 1 peter.junge 2002-11-28 17:59:30 UTC
Hi Falko,
1 4 U.
Peter
Comment 2 eric.savary 2003-04-16 15:43:39 UTC
Set to "NEW"
Comment 3 eric.savary 2003-04-16 15:44:17 UTC
Set to "NEW"
Comment 4 Unknown 2003-07-16 02:31:03 UTC
I noticed this behavior as well, but would like to add something (I 
think it's closely connected to this File->Open issue). The same 
happen if I specify this command-line: (using Windows XP)

ooocalc.exe tabdelimited.txt

The result is a rather illogical behavior to me; it's opened in Writer 
instead, even if I explicitly told OpenOffice to attempt to open it in 
Calc (since I know it's a tab delimited file). I'd rather see Calc 
bring up the Import Spreadsheet File dialog where I can specify 
delimiter characters, etc.

I seldom enter a command prompt to type that command line in, but that 
is what Windows executes in the background when right-clicking a file 
and selecting "Send To->OpenOffice.org Calc", if such a shortcut is 
placed in your SendTo-folder.
Comment 5 falko.tesch 2003-09-12 12:03:20 UTC
I concur. I also find it sometimes irritating that we _always_ open
.txt files with Writer.
We shoulsd find a way to workaround it.
Comment 6 falko.tesch 2003-09-12 12:03:43 UTC
started
Comment 7 frank 2003-09-25 15:34:34 UTC
*** Issue 20048 has been marked as a duplicate of this issue. ***
Comment 8 jagbass 2003-11-13 03:01:49 UTC
I think a solution for the command line part of this issue that might
be less work than trying to determine the file type smartly on the fly
would be to add command line options to direct the target application
and type of conversion.  For instance:

soffice -calc -convert=csv [fn]

One could then easily make a separate short cut for calc text imports
in the sendTo menu of windows, etc.

Admittedly not as elegant as detecting the file type on the fly but it
would get things rolling.
Comment 9 jagbass 2003-11-18 21:33:05 UTC
Another trick that Excel uses that might be usefull here is that one
can name a file ".xls" even though it's a tab delimited text file. 
Excel then applies a standard tab delimited conversion to the file
automatically.

I can't stress enough how important this issue is to me since I am
continually opening tab delimited text files as a spread sheet and
constantly navigating "File Open..." dialogs is tedious and
frustrating.  I would normally contribute a patch but I won't have
time to look at this for a number of months.
Comment 10 bettina.haberer 2003-12-05 18:04:12 UTC
Hello Niklas, please give approval for this evaluated OO.o 2.0 flagged
issue. 
If you confirm with the target OO.o 2.0, then please keep it on your
owner (or the owner of the concerning developer) for implementation.
In case you want this issue for 'OOo Later', then please reset the
target milestone. If you decline the issue finally, please set the
resolution to 'Wontfix' (but do not close). In case of 'OOo Later' or
'Wontfix' please reset it on Bettina's owner. Thank you.
Comment 11 guido.pinkernell 2003-12-11 16:15:02 UTC
*** Issue 22456 has been marked as a duplicate of this issue. ***
Comment 12 niklas.nebel 2004-01-26 11:17:42 UTC
It's a framework issue.
Comment 13 Mathias_Bauer 2004-01-26 13:22:48 UTC
We have discussed this problem widely and our opinion is that we don't want to
support a modul dependent *default* filter handling.
We will support a command line solution ("soffice.exe -calc ....") and we will
extend the extension list of our csv filter to support "xls" also. 
Our file dialog also will offer a much simpler way to open text files with Calc
than currently. Please stay tuned until the specification for this new feature
is published.
The target OOo2.0 is correct anyway, because this is an important user problem
we need to address.
Comment 14 andreas.schluens 2004-01-27 05:29:12 UTC
.
Comment 15 andreas.schluens 2004-01-30 13:42:08 UTC
.
Comment 16 andreas.schluens 2004-04-22 09:26:09 UTC
.
Comment 17 frank 2005-02-11 12:02:50 UTC
*** Issue 42078 has been marked as a duplicate of this issue. ***
Comment 18 ooo 2005-03-02 17:27:16 UTC
Note that there is a similar issue 23078.
Comment 19 frank 2005-04-13 15:58:08 UTC
*** Issue 46860 has been marked as a duplicate of this issue. ***
Comment 20 frank 2006-03-09 10:55:32 UTC
*** Issue 62492 has been marked as a duplicate of this issue. ***
Comment 21 abeverley 2007-01-13 14:05:50 UTC
If OpenOffice is to become widely used this is exactly the sort of issue that
needs addressing.

Here's what happened when I persuaded my father to try OpenOffice rather than
use MS Office:

The first thing he did was to open up some CSV files he has of some data. He
right-clicked on them and selected open with Calc. They opened up in Writer.

Then he actually opened Calc directly, and tried opening them from the open
menu. They opened up in Writer again.

At this point he was somewhat confused so had to give me a call to ask how to
open them in Calc.

I had to explain to him that he needed to scroll down the massive list of file
types (of which there are 118) and select 'Text CSV'. This worked but his
unsurprising response was 'rather obscure'!

Surely if you open a file from an application you expect it to open in that
application? You don't expect the computer to say 'well actually I think you
want to open that in this other application'.
Comment 22 abeverley 2007-01-13 14:06:24 UTC
If OpenOffice is to become widely used this is exactly the sort of issue that
needs addressing.

Here's what happened when I persuaded my father to try OpenOffice rather than
use MS Office:

The first thing he did was to open up some CSV files he has of some data. He
right-clicked on them and selected open with Calc. They opened up in Writer.

Then he actually opened Calc directly, and tried opening them from the open
menu. They opened up in Writer again.

At this point he was somewhat confused so had to give me a call to ask how to
open them in Calc.

I had to explain to him that he needed to scroll down the massive list of file
types (of which there are 118) and select 'Text CSV'. This worked but his
unsurprising response was 'rather obscure'!

Surely if you open a file from an application you expect it to open in that
application? You don't expect the computer to say 'well actually I think you
want to open that in this other application'.
Comment 23 andreas.schluens 2007-01-15 09:31:09 UTC
As already discussed within this bug (see MBA comments some lines before) ...
this wont be a possible solution. Nobody can say which behaviour the file open
dialog will have then ...

One example: Today it will be possible to open several file open dialog windows
at the same time. a) one from a writer document ... b) one from a calc document
... c) one from our quickstart module. But then the user cant say where it TXT
file will be opened. Only the file open dialog b) will make it right within this
context.

Solutions:
a) Name your file right. If it''s a CSV file ... use CSV not TXT as extension.
The format CSV does not exists. Any TXT file can be interpreted as CSV.
b) Use "scalc.exe" to open your text files as CSV format within calc.
c) Select the right filter inside the file open dialog.

I will open a new task, which points out the fact, that we think about a new
feature ....
OpenWith implemented by the file open dialog. but that  wont be related to the
TXT/CSV problem only.
Comment 24 abeverley 2007-01-16 20:13:11 UTC
Thanks for your response. OpenWith and then the ability to select application
would be very welcome.

What I was trying to point out is what the 'normal', non-computer savvy user
thinks, ie those users who we are trying to convert to OpenOffice. I understand
exactly the problem myself and I found a solution to do what I wanted; the
normal user may not, and will get frustrated. The normal user (in this case my
father), tried to open a file in one application and it opened in another...

As for running scalc.exe and then the name of the file, the Linux equivalent
didn't seem to work for me. I tried:

oocalc test.txt

and it opened in Writer. I then tried:

oocalc test.csv

and it opened in Calc. Is this the correct behaviour? If so, surely specifying
oocalc on the command line should definitely force it to open in Calc?

Verision is 2.02 on SLED 10
Comment 25 andreas.schluens 2007-01-23 08:33:54 UTC
I'm not sure ... but ate least an OOo 2.1 should support this feature on the
command line.
Comment 26 frank 2007-12-12 13:59:27 UTC
*** Issue 82601 has been marked as a duplicate of this issue. ***