Issue 91187

Summary: Power Regression isn't useful in current form
Product: General Reporter: enmane <nino>
Component: chartAssignee: kla <thomas.klarhoefer>
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description enmane 2008-06-29 05:37:57 UTC
Hi gang,
 I realize that trendline plotting and display is currently being worked on and
I'm hoping that one of the developers notes my comments.

 In its current form, plotting a trendline using the "power" option (versus
logarithm, linear, etc) isn't terribly useful.  In general the user should be
able to decide the order of the polynomial being used (e.g. 2nd order, 3rd, 4th,
5th, etc).  Having Calc/Chart _only_ using a 2nd order polynomial is pretty
useless.  Generally speaking, a best-fit analysis is performed on the order of
polynomial chosen to be used and then the curve is plotted and the equation
revealed.  

 In MANY cases that I've encountered, a higher order polynomial is required.  

The logic for determining the 2nd order polynomial equation that best fits
should be able to be ported to an nth-order polynomial so the work shouldn't be
too difficult.

I'd recommend a greyed-out user input field on the GUI used when determining the
 type of curve fit - if polynomial is chosen, then the greyed-out box becomes
active and the user can input the order of polynomial chosen and then OO goes
off and does its thing.  This is similar to how Excel works and, in general,
other curve-fitting packages.

I wouldn't call this an enhancement as the current form isn't really useful
until it can do higher order polynomials.

TIA,
enmane
Comment 1 kla 2008-07-03 12:43:33 UTC
duplicate

*** This issue has been marked as a duplicate of 20819 ***
Comment 2 kla 2008-07-04 15:43:16 UTC
closed, double