Issue 91301

Summary: Ellipsis-shortened text in templates dialog
Product: General Reporter: kai.sommerfeld
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: hdu, issues, philipp.lohmann
Version: DEV300m22   
Target Milestone: ---   
Hardware: All   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Screenshot none

Description kai.sommerfeld 2008-07-02 13:13:55 UTC
"My Documents" and "New Document" is shortened in templates dialog ("My ...",
"New ..."). See attached screen shot. User has no idea what functionality is
behind those points, I guess.
Comment 1 kai.sommerfeld 2008-07-02 13:17:36 UTC
Created attachment 54894 [details]
Screenshot
Comment 2 philipp.lohmann 2008-07-08 12:26:45 UTC
fixed in CWS aquavcl09
Comment 3 philipp.lohmann 2008-07-10 14:51:19 UTC
please verify in CWS aquavcl09

please note: you need a multimonitor configuration to see the problem
Comment 4 h.ilter 2008-07-15 11:42:33 UTC
HI->KSO: Could you please verify this. 
Me and PL were not able to reproduce the problem.
Comment 5 philipp.lohmann 2008-07-16 15:07:39 UTC
verified in CWS aquavcl09, if other issues come up, please file separate issue
Comment 6 kai.sommerfeld 2008-07-22 10:46:27 UTC
Sorry, but still broken in MWS m26. Reopened.
Comment 7 kai.sommerfeld 2008-07-22 10:47:18 UTC
pl: Your task again.
Comment 8 philipp.lohmann 2008-07-22 10:57:27 UTC
Not happening in 3.0 then.

@hdu: could you please have a try at coping with font sizes on kso's specific
system ? I tried and obviously failed.
Comment 9 hdu@apache.org 2008-10-22 12:45:40 UTC
The UI font size and resolution can make a difference indeed.

Now the real problem seems to be that the templates_dialog uses the TEXT_DRAW_ENDELLIPSIS style whereas the 
reporter kso cannot accept the ellipsis. So the quickest solutions would be to disable that style. The real solution 
would be to increase the size of the left pane to have enough room so that everything that needs to be displayed 
can be displayed.
Comment 10 philipp.lohmann 2008-10-22 12:57:53 UTC
sorry, the problem is that the font is too large and not as according to set
font ...
Comment 11 hdu@apache.org 2008-10-22 13:04:13 UTC
reassigning as suggested
Comment 12 philipp.lohmann 2008-10-22 13:12:02 UTC
target
Comment 13 philipp.lohmann 2009-04-01 10:40:02 UTC
It seems this is finally fixed with the changes in CWS ooo31gsl9 - OTOH I
thought that before. Can you please have a look with that CWS whether you cans
still reproduce this problem ?
Comment 14 kai.sommerfeld 2009-04-01 12:32:02 UTC
pl: Sorry, still no good in CWS ooo31gsl9. Text is still clipped.
Comment 15 philipp.lohmann 2009-04-23 13:50:25 UTC
back to the font expert. This can only be a problem of dpi vs. font dpi.
Comment 16 hdu@apache.org 2009-04-23 14:52:38 UTC
PL said that the potential fix in CWS ooo31gsl9 was to always reuse the calculated resolution when 
initializing frames. Incidentially in CWS vcl101 I just fixed a related issue 100885 where the resolution 
was always recalculated when a AquaSalVirtualDevice was created. So with the fixes in CWS ooo31gsl9 and  vcl101 combined the problem KSO had when he attached a big monitor while OOo was running should be 
gone for good.

@kso: please check with the vcl101 installset (which has both fixes since it was rebased to DEV300_m46)
Comment 17 kai.sommerfeld 2009-04-24 10:57:53 UTC
hdu: Sorry, still not fixed. Looks as ugly as before, even in m46 based CWS
vcl101 office...
Comment 18 hdu@apache.org 2009-04-24 14:09:05 UTC
Ok, KSO sees this also without hotplugging the monitor, so the dpi-recalculation is not the problem.

I had a closer look how splitter is positioned: well, let's just say there are some fancy calculations done in  
the SvtTemplateWindow object, which requests it's perfectly sized sub-windows to get resized to 
something else, less perfectly sized...

@cd: reassigning to you as PB's heir