Issue 91310

Summary: Linking of images in image controls, rather than embedding them into the database
Product: Base Reporter: encief <eandn>
Component: codeAssignee: marc.neumann
Status: CLOSED FIXED QA Contact: issues@dba <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 2.3.1   
Target Milestone: ---   
Hardware: All   
OS: Windows XP   
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description encief 2008-07-02 17:29:11 UTC
I am using 2.3.1 (and it is the same in 2.4.1) and I am embedding a picture in 
the database. To save space, I would like to link, rather than embedding. The 
link box is ticked but greyed out on the picture selection dialog box. Is this 
right? Is there an option I should be setting to link rather than embed?

Any help appreciated.
Comment 1 Frank Schönheit 2008-07-02 20:47:33 UTC
Linking to images, and displaying them in an image control, is currently not
possible. I would have though there already is an issue requesting it, but I
cannot find it. Confirming, grabbing, putting into the 3.x pool.
Comment 2 alex.thurgood 2008-07-03 09:51:27 UTC
@all

FYI

Roberto Benitez's book "Database Programming - OpenOffice.org Base & Basic"
shows you how to do this using macro magic and the file picker control. 

Alex
Comment 3 Frank Schönheit 2008-09-19 22:32:20 UTC
fixed in CWS dba31c

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba31c
Comment 4 Frank Schönheit 2008-11-04 13:41:17 UTC
for the record: submitted issue 95829 to implement a similar feature for
SRB-reports.
Comment 5 Frank Schönheit 2008-11-04 13:42:44 UTC
fs->msc: please verify in CWS dba31e
Comment 6 Frank Schönheit 2008-11-05 13:34:27 UTC
*** Issue 14454 has been marked as a duplicate of this issue. ***
Comment 7 marc.neumann 2008-11-11 13:19:42 UTC
verified in CWS dba31e

find more information about this CWS, like when it is available in the master
builds, in EIS, the Environment Information System:
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Path=DEV300%2Fdba31e
Comment 8 thorsten.ziehm 2009-07-20 14:52:46 UTC
This issue is closed automatically and wasn't rechecked in a current version of
OOo. The fixed issue should be integrated in OOo since more than half a year. If
you think this issue isn't fixed in a current version (OOo 3.1), please reopen
it and change the field 'Target Milestone' accordingly.

If you want to download a current version of OOo =>
http://download.openoffice.org/index.html
If you want to know more about the handling of fixed/verified issues =>
http://wiki.services.openoffice.org/wiki/Handle_fixed_verified_issues
Comment 9 thorsten.ziehm 2009-07-20 15:35:00 UTC
Sorry this issue was wrongly closed. This issue will be reopened automatically.
And will be set after that back to fixed/verified.
Comment 10 thorsten.ziehm 2009-07-20 15:39:32 UTC
Set to state 'fixed'.
Comment 11 thorsten.ziehm 2009-07-20 15:43:54 UTC
Set back to state 'verified/fixed'.

Again. Sorry for the mass of mails.