Issue 91474

Summary: Copying & pasting data from cell into another application will add an extra "white space" character to end of pasted data
Product: Calc Reporter: mark_jones <authentic8>
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: amy2008, issues, ooo.redflag, wsf
Version: OOo 2.4.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description mark_jones 2008-07-08 16:01:50 UTC
In the current 2.4 versions of OpenOffice Calc, when copying data from cells and
pasting into other applications, the resulting text always has an extra white
space character at the end (a CR/LF but manifests as a space depending on
whether the destination field is a multi-line or single line field). Note that
the white space does not display in the cell but only in the text that is pasted
to another application.

This was not the case in versions previous to 2.4 where there was no whitespace
after copying/pasting a cell value (I do not recall how far back but recent
enough to make me think it was 2.3 and before). 

While apparently trivial, it becomes a greater annoyance when this action must
be done regularly and the extra white space character has to keep being deleted.

Steps to reproduce:

1. Open a calc spreadsheet.
2. Enter a value into a cell.
3. Copy the same value from cell.
4. Paste the value into another text-based application (such as Notepad or a web
form in Mozilla)
5. Observe the extra white space character (or line feed) at the end of pasted data.
6 (optional). Try the above steps in older Calc versions and note the different
behaviour.

*NB. Not every application includes the extra character, I have observed e.g.
for some reason Internet Explorer 7 will strip it from text boxes and form fields.

*NB2. If the cell data was created in an older version of Calc it does not
contain the extra white space when pasted into another application.
Comment 1 amy2008 2008-08-12 06:46:07 UTC
In DEV300_m28 on WinXP, only select the cell then copy the cell, paste the 
cell into another text-based application (such as Notepad), it happens.
But if I select the value of the cell by double click, copy the value and 
paste it into another text-based application (such as Notepad), it doesn't 
happen.

So, please confire it in the latest build, mark_jones.

 
Comment 2 amy2008 2008-08-12 06:49:21 UTC
It is similar to the Issue 86436.
Comment 3 mark_jones 2010-03-02 19:05:03 UTC
This issue still occurs in 3.2 build 9483 but it does appear to be a duplicate
of Issue 86436. Marking as such.
Comment 4 mark_jones 2010-03-02 19:09:13 UTC
Well I would have marked it as a dup but it didn't seem to work. I'll try it
again otherwise someone else will have to do it. Thanks.
Comment 5 redflagzhulihua 2010-03-04 02:35:38 UTC
*** Issue 86436 has been marked as a duplicate of this issue. ***
Comment 6 redflagzhulihua 2010-03-04 02:40:34 UTC
confirmed.

because this description is more detailed. So I set i86436 as duplicate of this one.