Issue 91758

Summary: RTF: Numbered lists lose numbering in certain files created in MS Word
Product: Writer Reporter: maksym_kozub <maksym.kozub>
Component: open-importAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Major    
Priority: P3 CC: helenrussian, issues, knmc, tonal
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: All   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: 4.1.3
Developer Difficulty: ---
Attachments:
Description Flags
Simple example of the problem none

Description maksym_kozub 2008-07-17 11:40:51 UTC
When a very simple file (see the attachment) is opened in OO 2.4.1, the list 
has no numbers in it. The same applies to OO DEV300_m21 build, I want to use 
OO, but I have hundreds of my real documents (contracts etc, all of them being 
RTF) I have to continue to use, and they all have this numbering problem when 
opened in OO.
Comment 1 maksym_kozub 2008-07-17 11:43:00 UTC
Created attachment 55179 [details]
Simple example of the problem
Comment 2 michael.ruess 2008-07-17 15:26:59 UTC
MRU->OD: generally the numberings are imported from RTF, but in this sample it
does not work.
Comment 3 maksym_kozub 2008-07-30 11:14:01 UTC
The same issue is also present in OO 3.0 Beta 2.
Comment 4 Oliver-Rainer Wittmann 2008-09-04 12:53:51 UTC
OD->HBRINKM: 
Please take over this RTF import issue, Thx.
Comment 5 Risto Jääskeläinen 2008-09-27 17:28:25 UTC
With Vistas WordPad (what I regard as the RTF-editor) shows this:
1.	Begin
2.	End
Clicking same filename in directory from OOO3000_m7 produces this:
Begin
End

But words are in column A in rows 1 and 2 in Calc.

Suprising?

Best regards
Risto Jääskeläinen


Comment 6 Risto Jääskeläinen 2008-09-27 17:29:07 UTC
With Vistas WordPad (what I regard as the RTF-editor) shows this:
1.	Begin
2.	End
Clicking same filename in directory from OOO3000_m7 produces this:
Begin
End

But words are in column A in rows 1 and 2 in Calc.

Suprising?

Best regards
Risto Jääskeläinen


Comment 7 openoffice 2008-11-24 16:20:48 UTC
set target: lack of resources
Comment 8 tonal 2009-09-24 05:58:27 UTC
The same issue is also present in OO 3.1.1 :(
Comment 9 maksym_kozub 2010-02-01 15:39:23 UTC
3.2.0 RC4 still cuts numbered items in the same way.
Comment 10 maksym_kozub 2010-03-07 11:11:12 UTC
Same in OOo 3.2.0 release.
Comment 11 eric.savary 2010-09-21 19:41:16 UTC
*** Issue 114657 has been marked as a duplicate of this issue. ***
Comment 12 maksym_kozub 2012-05-08 16:02:19 UTC
Still the same in AOO340m1(Build 9590)- Rev. 1327774. LibreOffice 3.5 does not have this numbering problem when opening RTF files...
Comment 13 maksym_kozub 2017-05-17 18:58:22 UTC
Now, almost nine years after I first reported this bug, I have tested the file with AOO 4.1.3, and the bug is still there.
Comment 14 Keith N. McKenna 2017-05-17 22:50:01 UTC
Changed Version to 3.3.0 or older and Latest Confirmation to 4.1.3 to show the age of the bug
Comment 15 Marcus 2017-05-20 11:05:07 UTC
Reset assigne to the default "issues@openoffice.apache.org".