Issue 92421

Summary: The PPT document that save with password,OOo can't open or stop responding
Product: Impress Reporter: liujianli <liujianli>
Component: codeAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: issues, liujiaxiang
Version: OOo 2.4.1   
Target Milestone: OOo 3.2   
Hardware: All   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84291    
Attachments:
Description Flags
file encryption setting for the document to open.
none
file encryption setting for the document to modify.
none
establined two jurisdiction none

Description liujianli 2008-08-04 03:38:31 UTC
1. Start a presentation.
2. Please loading the attachment.

OOo can't open the document1 and document2  of the attachment.
When open the document3,the presentation stop responding.

Document1:File encryption setting for the document to open.
Document2:File encryption setting for the document to modify.
Document3:Established above two jurisdictions.
Comment 1 liujianli 2008-08-04 03:42:07 UTC
Created attachment 55522 [details]
file encryption setting for the document to open.
Comment 2 liujianli 2008-08-04 03:42:44 UTC
Created attachment 55523 [details]
file encryption setting for the document to modify.
Comment 3 liujianli 2008-08-04 03:53:54 UTC
Created attachment 55525 [details]
establined two jurisdiction
Comment 4 christoph.lukasiak 2008-08-04 15:48:41 UTC
i can confirm the described behavior

clu->liujianli: for the two first docs, please write a separate feature
enhancement issue, because the loading of password encrypted MS PP is not
supported, yet. thx.

clu->sj: the third doc loops, that should be fixed in time, thx.
Comment 5 christoph.lukasiak 2008-08-04 15:50:30 UTC
change owner
Comment 6 christoph.lukasiak 2008-08-04 16:09:34 UTC
clu->sj: VM(WinXP) shows an 'out of memory' warning and crashes the oo -> looks
like a memory leak
Comment 7 sven.jacobi 2009-03-13 18:22:13 UTC
This issue has been fixed now in cws[impress169] in
sd/source/filter/sdpptwrp.cxx -rev 269492.
Comment 8 sven.jacobi 2009-05-05 16:05:38 UTC
sj->wg: this issue is ready to be verified in cws[impress169]
Comment 9 wolframgarten 2009-05-15 12:45:32 UTC
Verified in CWS.
Comment 10 wolframgarten 2009-05-27 14:44:55 UTC
Tested in m49 and closed.