Issue 92458

Summary: Field for dictionary header guide words
Product: Writer Reporter: gtrihus <gtryus>
Component: formattingAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 3.0 Beta   
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Page 2 demonstrates guide words
none
Examples of homophones on pg 13 & 15 of sena3e.pdf none

Description gtrihus 2008-08-05 02:42:04 UTC
Dictionaries normally include the first word on the page in the header on 
the upper left and the last word on the page in the header on the upper 
right. I am calling these the guide words. Open office has a field code for 
chapter that allows a paragraph style to be specified and the contents of 
the paragraph with that style will be included in subsequent headers. This 
feature would be implemented with another field code that allowed the user 
to specify a character style and whether the first or last element of that 
style on the page should be used. (Similar to StyleRef in Word) Thus unlike
chapter, the first (or last) sequence of characters marked with this style on
the current page would appear in the header. (Note that some dictionary entires
are more than one word.) Some words will also have a homophone number after them
(usually superscripted or subscripted). Presumably if such a field code existed,
a second instance could be used to capture the homophone number on the first or
last entry (if there was one) and put it in the header. (Likely the formatting
of the homophone number would be like that in the entry and frequently the
homophone number on the first or last entry would be non-existant.
Comment 1 gtrihus 2008-08-05 02:44:00 UTC
Created attachment 55550 [details]
Page 2 demonstrates guide words
Comment 2 gtrihus 2008-08-05 03:08:02 UTC
Created attachment 55551 [details]
Examples of homophones on pg 13 & 15 of sena3e.pdf
Comment 3 gmailsankar 2008-08-05 05:27:56 UTC
*** Issue 92458 has been confirmed by votes. ***
Comment 4 jeeva1091 2008-08-05 05:46:34 UTC
Guidword will help us to improve the dictionary process
Comment 5 yesuspatham 2008-08-05 05:56:32 UTC
dictionary guidewords are helpful. It is more helpful to print it. It should 
reflect like the MSWORD
Comment 6 jprabu 2008-08-05 06:12:15 UTC
This issue really needed for my project
Comment 7 id_james 2008-08-05 06:13:58 UTC
Importent feature for our project
Comment 8 michael.ruess 2008-08-05 07:09:16 UTC
Already tracked as issue 22728. Feel free to add your comment there or vote for it.

*** This issue has been marked as a duplicate of 22728 ***
Comment 9 michael.ruess 2008-08-05 07:09:42 UTC
Closing duplicate.