Issue 92460

Summary: Writer crashes when inserting different kinds of files into master document via Navigator
Product: Writer Reporter: jian.li
Component: codeAssignee: eric.savary
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: amy2008, chengxiuzhi, esigra, issues, liujiaxiang, Mathias_Bauer, ooo.redflag, peter.junge
Version: DEV300m37Keywords: crash
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84291    

Description jian.li 2008-08-05 03:28:33 UTC
Description:
1. Create a master ducument;
2. Click "Insert" and choose "File" on the "Navigator" tool bar;
3. Pop up "Insert" dialog, choose several files(must include Non-text 
file,such as : .odp), Click "Insert" button;
4. Writer crashes.
Comment 1 michael.ruess 2008-08-05 06:59:30 UTC
Reassigned to ES.
Comment 2 eric.savary 2008-08-29 10:29:31 UTC
DoesN't crash on Windows Vista. Neither in 2.4.1 nor in OOO300m3.
Comment 3 eric.savary 2008-09-03 13:55:01 UTC
worksforme
Comment 4 eric.savary 2008-09-03 13:55:40 UTC
Closed
Comment 5 amy2008 2008-12-24 09:07:46 UTC
Can reproduce it with DEV300m37 on WinXP and Fedora
How to reproduce it (100% reproducible)
1 Open a new Master document
2 Insert - File on Navigator Toolbar, 'Insert' dialog opens, select two or more
  different kinds of files at the same time, e.g. 'select *.odt, CTRL, select
  *.ods or odp etc', Click Insert button
  Note: Two kinds of files must be selected at the same time with CTRL;
        Select *.odt firstly, select *.ods secondly;
        

Result 
OOo crashes

Expectation
OOo works well

Note:
If select odt document firstly, then select txt or doc document, odt shows red, 
namely can't find odt document;
If select odt document firstly, then select xls or MS ppt document, OOo crashes

Regards
Li Meiying
Comment 6 Mathias_Bauer 2009-05-25 12:27:52 UTC
This seems to be a duplicate of issue 98267. I suggest to keep the latter as it
already contains some discussions about a possible fix.


*** This issue has been marked as a duplicate of 98267 ***
Comment 7 Mechtilde 2009-07-12 17:57:48 UTC
duplicate -> closed