Issue 92755

Summary: dictionary full error
Product: General Reporter: bill_leach <william.leach>
Component: spell checkingAssignee: issues@lingucomponent <issues>
Status: CLOSED DUPLICATE QA Contact: issues@lingucomponent <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description bill_leach 2008-08-13 16:06:50 UTC
Initially ALL words were not recognized while using either writer or calc. 
Began adding words... added words were recognized as spelled correctly however,
I have received a "dictionary full" message and can not add any additional words.
Comment 1 thomas.lange 2008-08-14 06:33:31 UTC
This is a duplicate to issue 48676.

However it is not a real defect at all.
User dictionaries are meant to provide _limited_ means to modify spell checking
results. They are not meant to make up for missing or rather incomplete base
dictionaries.

There is a limit to how many entries can be shown in the dialog that edit
entries and that limit will even be smaller when the dialog should still be
usable and responsive in a reasonable amount of time.
Also having too many entries in a user dictionary may well have a negative
impact on the spell checking performance since similarity search is applied to
get proposals as well from those entries.

Still, the limit for the numbers of entries may be increased somewhat...


*** This issue has been marked as a duplicate of 48676 ***
Comment 2 Mechtilde 2008-11-05 21:33:03 UTC
close the duplicate