Issue 93255

Summary: chosen font not displaied in textfield properties
Product: Impress Reporter: amoroder2 <andreas.moroder>
Component: uiAssignee: AOO issues mailing list <issues>
Status: RESOLVED FIXED QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa
Version: OOo 2.4.1   
Target Milestone: ---   
Hardware: PC   
OS: Windows, all   
See Also: https://issues.apache.org/ooo/show_bug.cgi?id=123063
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
character_set_test.odp
none
character_set_test.ppt
none
Microsoft_Powerpoint_Font
none
OOO_Impress_Font none

Description amoroder2 2008-08-29 14:22:35 UTC
Hello,

- select a Textfield in design mode
- open the properties
- press the button to change the font
- select another font and [OK]
- the name of the new font is not shown in the properties

you have to press the mouse in the doc outside the textfield and then reselect
the textfield to see the fontname appear. The font size is never shown.

Bye
Andreas
Comment 1 michael.ruess 2008-08-29 15:48:39 UTC
Reassigned to MSC.
Comment 2 stefan.baltzer 2008-10-30 10:06:22 UTC
SBA: Change component to presentation.
Comment 3 janeowen 2009-01-31 21:47:26 UTC
Description:: 
Form Controls, Text Box Properties, Font Field - does not display current font 
until user forces a dialog refresh.
This refresh problem is not limited to the first attempt to change the font. 
The refresh problem exists for all font changes. 

You should not have to click away or close the properties dialog for this field 
to refresh with the most recent font selection. This could cause the customer 
to question whether the font changes were saved, lowering confidence in the 
product.
 
Configuration: 
Win XP SP2
OpenOffice.org 3.0.0 build 9358

To Reproduce:
1) Select Menu Item-> View -> Toolbars -> Form Control
2) Select the button with the ABC icon to add a text box, move your mouse and 
click on your slide to apply the textbox.
3) Right Click on your textbox and select Control (This brings up the 
Properties table).
4) Notice the font row – there is no font listed.
5) Click the font button and select a different font.
6) Notice the font row – still has no font listed.
7) There are several actions you can take now to get that font row refreshed 
with your current font
   a) Close and Reopen the properties dialog 
   b) Mouse click outside the Properties box AND outside the highlighted Text 
box then mouse click back on the Text box
Comment 4 swu 2009-09-02 17:14:45 UTC
Description:
I can repeat this issue using janeowen's directions. 

The field remains blank until the font is changed. This issues does seem to 
make the properties dialog box confusing.

Configuration:

Windows XP SP2
OpenOffice 3.1.1 OOO310m19 (Build:9420) 

Comment 5 mbryant 2009-09-10 02:27:31 UTC
I could not get the bug to be reproduced, I attempted to follow janeowen's steps
but I did not get the same result in the bug.

Listed are my steps from the opening of the program as to make sure that its not
step dependent, as well as my different configuration (I used windows 7, while
the other two listed are using XP SP2) and build to make sure that it was not
the build that made the difference as well.

Configuration
Windows 7 Professional (retail)
OOo-dev 3.2.0
DEV300m57 (Build:9422)

Steps Taken.

Launched from the start menu >> create document from empty template
Original settings >> create document
One the first slide Menu >> view >> toolbars >> form control
Clicked on wrong button first (label field) >> then text box
Created the text box in the slide >> right clicked and selected control
In the control menu scrolled down to font >> listed as (Default)
Changed Font to "Times New Roman" (no other settings) >> font name changed as
soon as font selection was completed.

I am not saying that the above issues are not present, but I was unable to
reproduce them. Following the same procedure I then selected a background color
of brown (from empty presentation) and was still unable to reproduce the issue.

On a side note next to the font name it lists any special characteristics (ie
bold, italics) as well as the font size if not default.
Comment 6 cemkaner 2009-09-11 08:06:59 UTC
I cannot replicate this using JaneOwen's steps either, but I believed she
submitted her confirmation as part of our bug advocacy class and if so, we
almost certainly replicated her report at the time, as part of the grading of
her assignment.  swu replicated this recently, but with an old version of OOo
(3.1.1)

My version of OOo is 3.2.0-dev m55 and like JaneOwen and swu, I am running XP.
mbryant also failed to replicate this with OOo-dev 3.2.0 DEV300m57.

Looks to me as though this bug has been fixed in 3.2.
Comment 7 justinrohrman 2011-02-20 01:43:03 UTC
Created attachment 75884 [details]
character_set_test.odp
Comment 8 justinrohrman 2011-02-20 01:43:31 UTC
Created attachment 75885 [details]
character_set_test.ppt
Comment 9 justinrohrman 2011-02-20 01:43:51 UTC
Created attachment 75886 [details]
Microsoft_Powerpoint_Font
Comment 10 justinrohrman 2011-02-20 01:44:16 UTC
Created attachment 75887 [details]
OOO_Impress_Font
Comment 11 Rainer Bielefeld 2014-01-25 16:29:10 UTC
Comment on attachment 75884 [details]
character_set_test.odp

Has nothing to do with reported Form Controls problem, so I obsolete the attachment.
Comment 12 Rainer Bielefeld 2014-01-25 16:29:23 UTC
Comment on attachment 75885 [details]
character_set_test.ppt

Has nothing to do with reported Form Controls problem, so I obsolete the attachment.
Comment 13 Rainer Bielefeld 2014-01-25 16:29:52 UTC
Comment on attachment 75887 [details]
OOO_Impress_Font

Has nothing to do with reported Form Controls problem, so I obsolete the attachment.
Comment 14 Rainer Bielefeld 2014-01-25 16:43:17 UTC
The problem is that in the Form Controls Control field the newly selected font will not be shown after change, sometimes more or less never.

Reproducible with "Ooo 3.1.1 German WIN7 Home Premium (64bit) DE [OOO310m19 (Build 9420)]" proceeding step by step instruction omment 2 and Comment 5

NO LONGER reproducible with 
* sever installation of "OOo 3.2.1 English UI / German locale [OOO320m18 
  (Build 9502)]" on WIN7 Home Premium (64bit) DE 
* "AOO 4.0.1 – German UI / German locale [Rev. 1524958 2013-09-20 11:40:29]" 
  on German WIN7 Home Premium (64bit)", “historic” 4.0 User Profile used for 
  all predecessor versions
* server installation of "AOO 4.1.0-Dev – English UI / German locale - 
  [AOO410m1(Build:9750) - Rev. 1559824 - 2014-01-22]" on German 
   WIN7 Home Premium (64bit)", own separate user profile

So CLOSED

   Has been fixed for OOo 3.2, but because of crippled Target Milestone
   selector contents (Bug 123063) I only can select TM = 4.1.0, no correct
   information can be contributed.
Comment 15 Rainer Bielefeld 2014-01-25 16:43:33 UTC
.